<!DOCTYPE html>
<html lang="en-US">
<head>
<meta name="google-site-verification" content="1f92YC9u0pt-oKDSRU3Go1mgdBnZkTfw19oXPTwEm_A" />
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width,initial-scale=1.0">
<link rel="pingback" href="https://frankreport.com/xmlrpc.php">
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="l6NHsVbzdFK5pLLe4Zgz_U2068QF7fYZ1dYncxdWz3I" />

	<!-- This site is optimized with the Yoast SEO plugin v18.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Swami Chetananda Demanded Female Disciples Pity F-k Homeless Men - Frank Report</title>
	<link rel="canonical" href="https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Swami Chetananda Demanded Female Disciples Pity F-k Homeless Men - Frank Report" />
	<meta property="og:description" content="FacebookTwitterRedditLinkedInEmail J. Michael Shoemaker was born in Connersville, Indiana, on July 25, 1949. The bright lad attended Indiana University. Sometimes, to amuse himself, he would go to the roof of his fraternity house and shoot off guns while high on speed. He stole the speed from his father&#8217;s pharmacy. His online biography states, &#8220;From his college [&hellip;]" />
	<meta property="og:url" content="https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/" />
	<meta property="og:site_name" content="Frank Report" />
	<meta property="article:published_time" content="2022-05-24T11:55:35+00:00" />
	<meta property="article:modified_time" content="2022-05-24T12:52:55+00:00" />
	<meta property="og:image" content="https://frankreport.com/wp-content/uploads/2022/05/swami-beast-2.jpg" />
	<meta property="og:image:width" content="910" />
	<meta property="og:image:height" content="1260" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Frank Parlato" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="14 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://frankreport.com/#website","url":"https://frankreport.com/","name":"Frank Report","description":"The truth is always fair.","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://frankreport.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/#primaryimage","url":"https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-beast-2.jpg?fit=910%2C1260&ssl=1","contentUrl":"https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-beast-2.jpg?fit=910%2C1260&ssl=1","width":910,"height":1260},{"@type":"WebPage","@id":"https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/#webpage","url":"https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/","name":"Swami Chetananda Demanded Female Disciples Pity F-k Homeless Men - Frank Report","isPartOf":{"@id":"https://frankreport.com/#website"},"primaryImageOfPage":{"@id":"https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/#primaryimage"},"datePublished":"2022-05-24T11:55:35+00:00","dateModified":"2022-05-24T12:52:55+00:00","author":{"@id":"https://frankreport.com/#/schema/person/8e84869a9f02771b2f51457a0101fc7f"},"breadcrumb":{"@id":"https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/"]}]},{"@type":"BreadcrumbList","@id":"https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://frankreport.com/"},{"@type":"ListItem","position":2,"name":"Swami Chetananda Demanded Female Disciples Pity F&#8212;k Homeless Men"}]},{"@type":"Person","@id":"https://frankreport.com/#/schema/person/8e84869a9f02771b2f51457a0101fc7f","name":"Frank Parlato","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://frankreport.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/4d9dd93b1ebf3c3c5a3912cf0d1329b3?s=96&d=identicon&r=g","contentUrl":"https://secure.gravatar.com/avatar/4d9dd93b1ebf3c3c5a3912cf0d1329b3?s=96&d=identicon&r=g","caption":"Frank Parlato"},"url":"https://frankreport.com/author/frankparlato/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Frank Report &raquo; Feed" href="https://frankreport.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Frank Report &raquo; Comments Feed" href="https://frankreport.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Frank Report &raquo; Swami Chetananda Demanded Female Disciples Pity F&#8212;k Homeless Men Comments Feed" href="https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/frankreport.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.3"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0cbfc627d735319fad4e098cb68f4bfd' href='https://frankreport.com/_static/??-eJyNUltSwzAMvBCuynSgXwxHYRRbTdz6kbFkQm6P84KWNqU/HkvWrlZad63SMQgFgdbl2gaGOpewolRDla0zULmoT8rZKmHqgaV3tNHMT9011GEfs6g6WXNZaIN22RDDkcGTsUiO/IA8D9oCp6Qc1aj7jbfhX3R5O4/PMYs0n9Wirmt19NzAJwUTE2CW6FHEahD6kolJddbUJGpUz1DIYM4MNWtzDzFqUYeYvNrDj94BPjGtIUtKopLOilAa6+e7OhCZNdSRpEV9Ah9NHmQ6eyK+bY00ZTUMDSUsXiIzyaTrxq4Wek8nVuwxlT1EbdHNW/md5y6SkPsFyA0mumiL632ZMOmmPDj7SQqP+KWm1EIwu3JXgmDlqE3EUz9DB8zu5te4RqhytDHw0H7MThw3C+4x/vVHY4qZyQF3ti3eVjmY9QlW0fODWhKPEowmGDSmH6821P8hP8oXhtlCF+vIF8Ejow97m+9D6bt/e3592W33u/129w2LM7Yi' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='herald-main-inline-css'>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</style>
<style id='meks_ess-main-inline-css'>

                body .meks_ess a {
                    background: #000000 !important;
                }
                body .meks_ess.transparent a::before, body .meks_ess.transparent a span, body .meks_ess.outline a span {
                    color: #000000 !important;
                }
                body .meks_ess.outline a::before {
                    color: #000000 !important;
                }
                body .meks_ess.outline a {
                    border-color: #000000 !important;
                }
                body .meks_ess.outline a:hover {
                    border-color: #000000 !important;
                }
            
</style>
<style id='global-styles-inline-css'>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</style>
<link rel='stylesheet' id='herald-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%7CLato%3A400%2C700&#038;subset=latin%2Clatin-ext&#038;ver=1.7' media='all' />
<script src='https://www.googletagmanager.com/gtag/js?id=UA-102321608-1&#038;ver=5.9.3' id='wk-analytics-script-js'></script>
<script id='wk-analytics-script-js-after'>
function shouldTrack(){
var trackLoggedIn = true;
var loggedIn = false;
if(!loggedIn){
return true;
} else if( trackLoggedIn ) {
return true;
}
return false;
}
function hasWKGoogleAnalyticsCookie() {
return (new RegExp('wp_wk_ga_untrack_' + document.location.hostname)).test(document.cookie);
}
if (!hasWKGoogleAnalyticsCookie() && shouldTrack()) {
//Google Analytics
window.dataLayer = window.dataLayer || [];
function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-102321608-1');
}
</script>
<script src='https://frankreport.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript'  src='https://frankreport.com/wp-includes/js/jquery/jquery-migrate.min.js?m=1605690366'></script>
<link rel="https://api.w.org/" href="https://frankreport.com/wp-json/" /><link rel="alternate" type="application/json" href="https://frankreport.com/wp-json/wp/v2/posts/195194" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://frankreport.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://frankreport.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/p703zd-OMi' />
<link rel="alternate" type="application/json+oembed" href="https://frankreport.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffrankreport.com%2F2022%2F05%2F24%2Fswami-chetananda-demanded-female-disciples-pity-f-k-homeless-men%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://frankreport.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffrankreport.com%2F2022%2F05%2F24%2Fswami-chetananda-demanded-female-disciples-pity-f-k-homeless-men%2F&#038;format=xml" />
<style>img#wpstats{display:none}</style>
			<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<style type="text/css">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</style><link rel="icon" href="https://i0.wp.com/frankreport.com/wp-content/uploads/2018/02/cropped-FrankReportFavIcon.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/frankreport.com/wp-content/uploads/2018/02/cropped-FrankReportFavIcon.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/frankreport.com/wp-content/uploads/2018/02/cropped-FrankReportFavIcon.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/frankreport.com/wp-content/uploads/2018/02/cropped-FrankReportFavIcon.png?fit=270%2C270&#038;ssl=1" />
<style type="text/css">.wp-caption { max-width: 100% !important; text-align:center; } .wp-caption img { background:none; margin:0; border:0 none; max-width:100%; width:auto; height:auto;} .wp-caption-text, .gallery-caption { color:#000000; font-size:16px; margin:0; padding:4px 0 0; font-style: italic; text-align:center; } .wp-caption.aligncenter { margin:0 auto 15px; } .wp-caption { max-width:1100px; text-align:center;} .herald-logo-mini { margin-bottom: 20px; }</style><style type="text/css" id="wp-custom-css">/* Removes the right border on TDs on Select Acknowledgements page 24590717hc */ 
.page-id-151487 td {
    border-right: none;
}

/* Removes left border from tables on Select Acknowledgements page 24590717hc */ 
.page-id-151487 table {
    border-left: none;
}

.comment-reply-title {
	font-size: 20px;
	margin-bottom: 10px;
}

.header-top a {
    color: #b28e4d;
	
}

.herald-mobile-nav li a {
    color: #b28e4d;
}

.herald-responsive-header, .herald-mobile-nav, .herald-responsive-header .herald-menu-popup-search .fa {
    color: #b28e4d;
}

.herald-site-header .header-top, .header-top .herald-in-popup, .header-top .herald-menu ul {
    color: #b28e4d;
}

.herald-search-input {
	color: #b28e4d;
	background-color: black;
}


.header-middle .sub-menu > li > a, .header-middle .herald-search-submit, .header-middle li.herald-mega-menu .col-lg-3 a {
    color: #b28e4d;
}

input[type="text"], input[type="email"], input[type="url"], input[type="tel"], input[type="number"], input[type="date"], input[type="password"], select, textarea, .herald-single-sticky, td, th, table, .mks_author_widget .mks_autor_link_wrap a, .mks_read_more a, .herald-read-more {
    border-color: #b28e4d;
}
.header-middle .herald-search-input {
    color: #FFF;
}

.wp-caption-text {
text-align:left;
}

input[type="submit"], .spinner > div {
    background-color: #000;
}</style><!-- Jetpack Google Analytics -->
			<script type='text/javascript'>
				var _gaq = _gaq || [];
				_gaq.push(['_setAccount', 'UA-71092828-1']);
_gaq.push(['_trackPageview']);
				(function() {
					var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
					ga.src = ('https:' === document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
					var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
				})();
			</script>
			<!-- End Jetpack Google Analytics -->
</head>

<body class="post-template-default single single-post postid-195194 single-format-standard chrome herald-boxed">



	<header id="header" class="herald-site-header">

											<div class="header-middle herald-header-wraper hidden-xs hidden-sm">
	<div class="container">
		<div class="row">
				<div class="col-lg-12 hel-el">
				
															<div class="hel-l herald-go-hor">
													<div class="site-branding">
				<span class="site-title h1"><a href="https://frankreport.com/" rel="home"><img class="herald-logo" src="https://frankreport.com/wp-content/uploads/2021/11/logo-resized-1.svg" alt="Frank Report" ></a></span>
	</div>
											</div>
					
										
													
					
				
				</div>
		</div>
		</div>
</div>							<div class="header-top hidden-xs hidden-sm">
	<div class="container">
		<div class="row">
			<div class="col-lg-12">
				
												<div class="hel-l">
											<nav class="secondary-navigation herald-menu">	
		<ul id="menu-top-menu-desktop" class="menu"><li id="menu-item-36" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36"><a href="https://www.frankreport.com">Frank Report</a></li>
<li id="menu-item-156454" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156454"><a href="https://frankreport.com/the-lost-women-of-nxivm/">The Lost Women of Nxivm</a></li>
<li id="menu-item-152775" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152775"><a href="https://frankreport.com/endorsements/">Comments on Frank</a></li>
<li id="menu-item-156216" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156216"><a href="https://frankreport.com/appearances/">Appearances</a></li>
<li id="menu-item-177841" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-177841"><a href="https://frankreport.com/world-wide-media-reports-crediting-frank-parlato-oct-2018-to-present/">Media Credits</a></li>
<li id="menu-item-156249" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156249"><a href="https://frankreport.com/the-complete-book-quotes-on-frank-parlato/">Book Mentions</a></li>
<li id="menu-item-151518" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151518"><a href="https://frankreport.com/select-acknowledgements-from-mainstream-media-about-frank-parlato/">Select Media Mentions</a></li>
<li id="menu-item-140" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-140"><a href="https://frankreport.com/contact/">Contact</a></li>
</ul></nav>
									</div>
				
												<div class="hel-r">
											<div class="herald-menu-popup-search">
<span class="fa fa-search"></span>
	<div class="herald-in-popup">
		<form class="herald-search-form" action="https://frankreport.com/" method="get">
	<input name="s" data-swplive="true" data-swpengine="default" data-swpconfig="default" class="herald-search-input" type="text" value="" placeholder="Type here to search..." /><button type="submit" class="herald-search-submit"></button>
</form>	</div>
</div>									</div>
				
								
			</div>
		</div>
	</div>
</div>					
	</header>

			<div id="sticky-header" class="herald-header-sticky herald-header-wraper herald-slide hidden-xs hidden-sm">
	<div class="container">
		<div class="row">
				<div class="col-lg-12 hel-el">
				
															<div class="hel-l herald-go-hor">
													<div class="site-branding">
				<span class="site-title h1"><a href="https://frankreport.com/" rel="home"><img class="herald-logo" src="https://frankreport.com/wp-content/uploads/2021/11/logo-resized-1.svg" alt="Frank Report" ></a></span>
	</div>
											</div>
					
										
															<div class="hel-r herald-go-hor">
													<div class="herald-menu-popup-search">
<span class="fa fa-search"></span>
	<div class="herald-in-popup">
		<form class="herald-search-form" action="https://frankreport.com/" method="get">
	<input name="s" data-swplive="true" data-swpengine="default" data-swpconfig="default" class="herald-search-input" type="text" value="" placeholder="Type here to search..." /><button type="submit" class="herald-search-submit"></button>
</form>	</div>
</div>											</div>
										
					
				
				</div>
		</div>
		</div>
</div>	
	<div id="herald-responsive-header" class="herald-responsive-header herald-slide hidden-lg hidden-md">
	<div class="container">
		<div class="herald-nav-toggle"><i class="fa fa-bars"></i></div>
				<div class="site-branding mini">
		<span class="site-title h1"><a href="https://frankreport.com/" rel="home"><img class="herald-logo-mini" src="https://frankreport.com/wp-content/uploads/2021/11/logo-resized-1.svg" alt="Frank Report" ></a></span>
</div>		<div class="herald-menu-popup-search">
<span class="fa fa-search"></span>
	<div class="herald-in-popup">
		<form class="herald-search-form" action="https://frankreport.com/" method="get">
	<input name="s" data-swplive="true" data-swpengine="default" data-swpconfig="default" class="herald-search-input" type="text" value="" placeholder="Type here to search..." /><button type="submit" class="herald-search-submit"></button>
</form>	</div>
</div>	</div>
</div>
<div class="herald-mobile-nav herald-slide hidden-lg hidden-md">
	<ul id="menu-mobile-menu" class="herald-mob-nav"><li id="menu-item-177678" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-177678"><a href="/">Home</a></li>
<li id="menu-item-156175" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156175"><a href="https://frankreport.com/appearances/">Appearances</a></li>
<li id="menu-item-154844" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154844"><a href="https://frankreport.com/the-complete-book-quotes-on-frank-parlato/">Book Mentions</a></li>
<li id="menu-item-152282" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152282"><a href="https://frankreport.com/endorsements/">Comments on Frank</a></li>
<li id="menu-item-177679" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-177679"><a href="/contact">Contact</a></li>
<li id="menu-item-148825" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-148825"><a href="https://frankreport.com/world-wide-media-reports-crediting-frank-parlato-oct-2018-to-present/">Media Credits</a></li>
<li id="menu-item-119160" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-119160"><a href="https://frankreport.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-151513" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151513"><a href="https://frankreport.com/select-acknowledgements-from-mainstream-media-about-frank-parlato/">Select Mainstream Mentions</a></li>
<li id="menu-item-151589" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151589"><a href="https://frankreport.com/investigation-discoverys-the-lost-women-of-nxivm-with-frank-parlato-shows-an-even-darker-view-of-nxivm-than-hbos-the-vow/">The Lost Women of Nxivm</a></li>
</ul>	
					</div>
	
	<div id="content" class="herald-site-content herald-slide">

	


<div class="herald-section container ">

			<article id="post-195194" class="herald-single post-195194 post type-post status-publish format-standard has-post-thumbnail hentry category-general">
			<div class="row">
								
			
<div class="col-lg-9 col-md-9 col-mod-single col-mod-main">
	
	<header class="entry-header">
		<h1 class="entry-title h1">Swami Chetananda Demanded Female Disciples Pity F&#8212;k Homeless Men</h1>			<div class="entry-meta entry-meta-single"><div class="meta-item herald-date"><span class="updated">May 24, 2022</span></div></div>
	</header>		<div class="herald-post-thumbnail herald-post-thumbnail-single">
		<span><img width="910" height="1260" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-beast-2.jpg?fit=910%2C1260&amp;ssl=1" class="attachment-herald-lay-single size-herald-lay-single wp-post-image" alt="" srcset="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-beast-2.jpg?w=910&amp;ssl=1 910w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-beast-2.jpg?resize=217%2C300&amp;ssl=1 217w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-beast-2.jpg?resize=740%2C1024&amp;ssl=1 740w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-beast-2.jpg?resize=768%2C1063&amp;ssl=1 768w" sizes="(max-width: 910px) 100vw, 910px" data-attachment-id="195355" data-permalink="https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/swami-beast-2/" data-orig-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-beast-2.jpg?fit=910%2C1260&amp;ssl=1" data-orig-size="910,1260" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="swami beast 2" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-beast-2.jpg?fit=217%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-beast-2.jpg?fit=740%2C1024&amp;ssl=1" /></span>
			</div>
	
		<div class="row">

			

	<div class="col-lg-2 col-md-2 col-sm-2 hidden-xs herald-left">

				
		<div class="entry-meta-wrapper ">

					<div class="meta-ad"></div>
		
					<div class="entry-meta-author">					

			
				<img alt='' src='https://frankreport.com/wp-content/uploads/2021/10/FRANK-REPORT_LOGO_FINAL_B-on-G.jpg' srcset='https://frankreport.com/wp-content/uploads/2021/10/FRANK-REPORT_LOGO_FINAL_B-on-G.jpg 2x' class='avatar avatar-112 photo sab-custom-avatar' height='112' width='112' />				
				<a class="herald-author-name" href="https://frankreport.com/author/frankparlato/">Frank Parlato</a>

				
			
			</div>

		
					<div class="entry-meta entry-meta-single"><div class="meta-item herald-time"><span class="updated">6:55 am</span></div><div class="meta-item herald-comments"><a href="https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/#respond">Add Comment</a></div></div>
		
		
		
		</div>

	</div>


			<div class="col-lg-10 col-md-10 col-sm-10">
				<div class="entry-content herald-entry-content">

	
	
					
	<div class="meks_ess layout-3-2 circle no-labels outline"><a href="#" onclick="return false;" class="meks_ess-item socicon-facebook" data-url="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Ffrankreport.com%2F2022%2F05%2F24%2Fswami-chetananda-demanded-female-disciples-pity-f-k-homeless-men%2F&amp;t=Swami%20Chetananda%20Demanded%20Female%20Disciples%20Pity%20F%E2%80%94k%20Homeless%20Men"><span>Facebook</span></a><a href="#" onclick="return false;" class="meks_ess-item socicon-twitter" data-url="http://twitter.com/intent/tweet?url=https%3A%2F%2Ffrankreport.com%2F2022%2F05%2F24%2Fswami-chetananda-demanded-female-disciples-pity-f-k-homeless-men%2F&amp;text=Swami%20Chetananda%20Demanded%20Female%20Disciples%20Pity%20F%E2%80%94k%20Homeless%20Men"><span>Twitter</span></a><a href="#" onclick="return false;"  class="meks_ess-item socicon-reddit" data-url="http://www.reddit.com/submit?url=https%3A%2F%2Ffrankreport.com%2F2022%2F05%2F24%2Fswami-chetananda-demanded-female-disciples-pity-f-k-homeless-men%2F&amp;title=Swami%20Chetananda%20Demanded%20Female%20Disciples%20Pity%20F%E2%80%94k%20Homeless%20Men"><span>Reddit</span></a><a href="#" onclick="return false;"  class="meks_ess-item socicon-linkedin" data-url="https://www.linkedin.com/cws/share?url=https%3A%2F%2Ffrankreport.com%2F2022%2F05%2F24%2Fswami-chetananda-demanded-female-disciples-pity-f-k-homeless-men%2F"><span>LinkedIn</span></a><a href="mailto:?subject=Swami%20Chetananda%20Demanded%20Female%20Disciples%20Pity%20F%E2%80%94k%20Homeless%20Men&amp;body=https%3A%2F%2Ffrankreport.com%2F2022%2F05%2F24%2Fswami-chetananda-demanded-female-disciples-pity-f-k-homeless-men%2F" class="meks_ess-item  socicon-mail prevent-share-popup "><span>Email</span></a></div><div>
<div class="" data-block="true" data-editor="enka2" data-offset-key="5otof-0-0">
<div class="public-DraftStyleDefault-block public-DraftStyleDefault-ltr" data-offset-key="5otof-0-0"></div>
</div>
<div class="" data-block="true" data-editor="enka2" data-offset-key="5n0el-0-0">
<div class="public-DraftStyleDefault-block public-DraftStyleDefault-ltr" data-offset-key="5n0el-0-0">
<div class="" data-block="true" data-editor="enka2" data-offset-key="6bboe-0-0">
<div class="public-DraftStyleDefault-block public-DraftStyleDefault-ltr" data-offset-key="6bboe-0-0">
<p>J. Michael Shoemaker was born in Connersville, Indiana, on July 25, 1949. The bright lad attended Indiana University. Sometimes, to amuse himself, he would go to the roof of his fraternity house and shoot off guns while high on speed. He stole the speed from his father&#8217;s pharmacy.</p>
</div>
<div data-offset-key="6bboe-0-0"></div>
<div data-offset-key="6bboe-0-0"><a class="editor-rtfLink" href="http://nityanandainstitute.org/sc_bio.php" target="_blank" rel="noopener"><span data-preserver-spaces="true">His online biography</span></a><span data-preserver-spaces="true"> states, &#8220;From his college days, he knew he wanted his life to be about helping people and creating positive change in the world.&#8221;</span></div>
<div class="public-DraftStyleDefault-block public-DraftStyleDefault-ltr" data-offset-key="6bboe-0-0">
<p><span data-preserver-spaces="true"><br />
In 1971, he met a fat, gay businessman, </span><a class="editor-rtfLink" href="http://nityanandainstitute.org/lineage_rudi.php" target="_blank" rel="noopener"><span data-preserver-spaces="true">Albert Rudolph, or Rudi.</span></a><span data-preserver-spaces="true"> This corpulent gent used the &#8216;guru-technique&#8217; to have sex with lots of young men and boys who would otherwise be repulsed by him.</span></p>
<figure id="attachment_195395" aria-describedby="caption-attachment-195395" style="width: 354px" class="wp-caption alignnone"><img data-attachment-id="195395" data-permalink="https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/rudi-and-swami-chnet/" data-orig-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/rudi-and-swami-chnet.jpg?fit=1247%2C1552&amp;ssl=1" data-orig-size="1247,1552" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="rudi and swami chnet" data-image-description="" data-image-caption="&lt;p&gt;Rudi with young Shoemaker and another lad. Rudi spoke of high spiritual philosophy as he contemplated getting into their trousers.&lt;/p&gt;
" data-medium-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/rudi-and-swami-chnet.jpg?fit=241%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/rudi-and-swami-chnet.jpg?fit=823%2C1024&amp;ssl=1" loading="lazy" class=" wp-image-195395" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/rudi-and-swami-chnet.jpg?resize=354%2C441&#038;ssl=1" alt="" width="354" height="441" srcset="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/rudi-and-swami-chnet.jpg?resize=241%2C300&amp;ssl=1 241w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/rudi-and-swami-chnet.jpg?resize=823%2C1024&amp;ssl=1 823w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/rudi-and-swami-chnet.jpg?resize=768%2C956&amp;ssl=1 768w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/rudi-and-swami-chnet.jpg?resize=1234%2C1536&amp;ssl=1 1234w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/rudi-and-swami-chnet.jpg?resize=990%2C1232&amp;ssl=1 990w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/rudi-and-swami-chnet.jpg?w=1247&amp;ssl=1 1247w" sizes="(max-width: 354px) 100vw, 354px" data-recalc-dims="1" /><figcaption id="caption-attachment-195395" class="wp-caption-text">Rudi with young Shoemaker and another lad. Rudi spoke of high spiritual philosophy as he contemplated getting into their trousers.</figcaption></figure>
</div>
<div data-offset-key="6bboe-0-0"></div>
<div class="public-DraftStyleDefault-block public-DraftStyleDefault-ltr" data-offset-key="6bboe-0-0">
<p><span data-offset-key="eh1t-0-0">Shoemaker said about his first meeting with Rudi, &#8220;When I walked into his store, I looked at him and felt my heart shatter into a thousand pieces. From that moment on, I never had one second&#8217;s doubt about the power of the experience into which I had entered.&#8221;</span></p>
</div>
<div data-offset-key="6bboe-0-0">Shoemaker soon surrendered his body and soul, his heart, mind, and anus, to his lascivious but all-knowing guru. In certain circles, Shoemaker was known as Rudi&#8217;s boy.</div>
</div>
<div data-offset-key="6bboe-0-0"><span data-offset-key="eh1t-0-0"><img data-attachment-id="189872" data-permalink="https://frankreport.com/2022/04/11/strangulation-swami-cant-get-hard-without-it/rudi-and-shoemaker/" data-orig-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/rudi-and-shoemaker.jpg?fit=1182%2C625&amp;ssl=1" data-orig-size="1182,625" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="rudi and shoemaker" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/rudi-and-shoemaker.jpg?fit=300%2C159&amp;ssl=1" data-large-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/rudi-and-shoemaker.jpg?fit=1024%2C541&amp;ssl=1" loading="lazy" class="alignnone wp-image-189872" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/rudi-and-shoemaker.jpg?resize=411%2C218&#038;ssl=1" alt="" width="411" height="218" srcset="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/rudi-and-shoemaker.jpg?resize=300%2C159&amp;ssl=1 300w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/rudi-and-shoemaker.jpg?resize=1024%2C541&amp;ssl=1 1024w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/rudi-and-shoemaker.jpg?resize=768%2C406&amp;ssl=1 768w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/rudi-and-shoemaker.jpg?resize=990%2C523&amp;ssl=1 990w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/rudi-and-shoemaker.jpg?w=1182&amp;ssl=1 1182w" sizes="(max-width: 411px) 100vw, 411px" data-recalc-dims="1" /></span></div>
<div data-offset-key="6bboe-0-0"><span style="font-family: -apple-system, BlinkMacSystemFont, 'Segoe UI', Roboto, Oxygen-Sans, Ubuntu, Cantarell, 'Helvetica Neue', sans-serif;">Sita, one of Shoemaker&#8217;s former disciples, said, &#8220;He was weirdly in love with Rudi. He likes men. He likes to be sadistic with women. He told me how good it felt to have sex with men.&#8221;<br />
</span></div>
<div data-offset-key="6bboe-0-0">
<figure id="attachment_195341" aria-describedby="caption-attachment-195341" style="width: 588px" class="wp-caption alignnone"><img data-attachment-id="195341" data-permalink="https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/chet-swami-rudi-e/" data-orig-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-rudi-e.jpg?fit=2502%2C1605&amp;ssl=1" data-orig-size="2502,1605" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="chet swami rudi e" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-rudi-e.jpg?fit=300%2C192&amp;ssl=1" data-large-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-rudi-e.jpg?fit=1024%2C657&amp;ssl=1" loading="lazy" class="wp-image-195341" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-rudi-e.jpg?resize=588%2C378&#038;ssl=1" alt="" width="588" height="378" srcset="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-rudi-e.jpg?resize=300%2C192&amp;ssl=1 300w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-rudi-e.jpg?resize=1024%2C657&amp;ssl=1 1024w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-rudi-e.jpg?resize=768%2C493&amp;ssl=1 768w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-rudi-e.jpg?resize=1536%2C985&amp;ssl=1 1536w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-rudi-e.jpg?resize=2048%2C1314&amp;ssl=1 2048w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-rudi-e.jpg?resize=990%2C635&amp;ssl=1 990w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-rudi-e.jpg?resize=1320%2C847&amp;ssl=1 1320w" sizes="(max-width: 588px) 100vw, 588px" data-recalc-dims="1" /><figcaption id="caption-attachment-195341" class="wp-caption-text">Shoemaker was young and gay &#8211; just like Rudi liked &#8217;em.</figcaption></figure>
</div>
<div data-offset-key="6bboe-0-0">
<p>Happily, Rudi died in a plane crash shortly afterward, and Shoemaker claimed to be his successor.</p>
<p>Chetananda&#8217;s bio states, &#8220;Rudi, before his passing in 1973, gave Swamiji the opportunity to carry on his work and take over direction of his ashrams (spiritual communities) around the world.&#8221;</p>
<p>Some believe that Shoemaker fought and clawed his way to take over Rudi&#8217;s gullible followers and his assets. They say that a supposed &#8220;letter&#8221; Shoemaker got from Rudi saying he was to be his successor was non-existent. Shoemaker apparently never showed the letter to anyone.</p>
</div>
<div class="" data-block="true" data-editor="enka2" data-offset-key="6bboe-0-0">
<div class="public-DraftStyleDefault-block public-DraftStyleDefault-ltr" data-offset-key="6bboe-0-0">
<figure id="attachment_189883" aria-describedby="caption-attachment-189883" style="width: 345px" class="wp-caption alignnone"><img data-attachment-id="189883" data-permalink="https://frankreport.com/2022/04/11/strangulation-swami-cant-get-hard-without-it/shoemaker-and-rudi/" data-orig-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/shoemaker-and-rudi.jpg?fit=1000%2C1085&amp;ssl=1" data-orig-size="1000,1085" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="shoemaker and rudi" data-image-description="" data-image-caption="&lt;p&gt;Shoemaker and Rudi &lt;/p&gt;
" data-medium-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/shoemaker-and-rudi.jpg?fit=276%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/shoemaker-and-rudi.jpg?fit=944%2C1024&amp;ssl=1" loading="lazy" class=" wp-image-189883" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/shoemaker-and-rudi.jpg?resize=345%2C374&#038;ssl=1" alt="" width="345" height="374" srcset="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/shoemaker-and-rudi.jpg?resize=276%2C300&amp;ssl=1 276w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/shoemaker-and-rudi.jpg?resize=944%2C1024&amp;ssl=1 944w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/shoemaker-and-rudi.jpg?resize=768%2C833&amp;ssl=1 768w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/shoemaker-and-rudi.jpg?resize=990%2C1074&amp;ssl=1 990w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/shoemaker-and-rudi.jpg?w=1000&amp;ssl=1 1000w" sizes="(max-width: 345px) 100vw, 345px" data-recalc-dims="1" /><figcaption id="caption-attachment-189883" class="wp-caption-text">Shoemaker and Rudi</figcaption></figure>
<figure id="attachment_194438" aria-describedby="caption-attachment-194438" style="width: 329px" class="wp-caption alignnone"><img data-attachment-id="194438" data-permalink="https://frankreport.com/2022/05/17/bat-wielding-swami-sent-woman-to-gang-bang/swami-and-rudi/" data-orig-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-and-rudi.jpg?fit=1280%2C1515&amp;ssl=1" data-orig-size="1280,1515" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="swami and rudi" data-image-description="" data-image-caption="&lt;p&gt;The Swami Chetananda&lt;/p&gt;
" data-medium-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-and-rudi.jpg?fit=253%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-and-rudi.jpg?fit=865%2C1024&amp;ssl=1" loading="lazy" class=" wp-image-194438" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-and-rudi.jpg?resize=329%2C389&#038;ssl=1" alt="" width="329" height="389" srcset="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-and-rudi.jpg?resize=253%2C300&amp;ssl=1 253w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-and-rudi.jpg?resize=865%2C1024&amp;ssl=1 865w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-and-rudi.jpg?resize=768%2C909&amp;ssl=1 768w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-and-rudi.jpg?resize=990%2C1172&amp;ssl=1 990w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-and-rudi.jpg?w=1280&amp;ssl=1 1280w" sizes="(max-width: 329px) 100vw, 329px" data-recalc-dims="1" /><figcaption id="caption-attachment-194438" class="wp-caption-text">The Swami Chetananda with a statue of Rudi in his ashram in Gold Beach. He has people do ceremonial worship of Rudi daily. Chetananda claims to have Rudi&#8217;s ashes which are said to be worshipped. But some doubt that the ashes are in Chetananda&#8217;s possession.</figcaption></figure>
</div>
<figure id="attachment_195259" aria-describedby="caption-attachment-195259" style="width: 308px" class="wp-caption alignnone"><img data-attachment-id="195259" data-permalink="https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/chet-swami-rudi/" data-orig-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-rudi.jpg?fit=1272%2C1567&amp;ssl=1" data-orig-size="1272,1567" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="chet swami rudi" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-rudi.jpg?fit=244%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-rudi.jpg?fit=831%2C1024&amp;ssl=1" loading="lazy" class="wp-image-195259" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-rudi.jpg?resize=308%2C379&#038;ssl=1" alt="" width="308" height="379" srcset="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-rudi.jpg?resize=244%2C300&amp;ssl=1 244w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-rudi.jpg?resize=831%2C1024&amp;ssl=1 831w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-rudi.jpg?resize=768%2C946&amp;ssl=1 768w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-rudi.jpg?resize=1247%2C1536&amp;ssl=1 1247w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-rudi.jpg?resize=990%2C1220&amp;ssl=1 990w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-rudi.jpg?w=1272&amp;ssl=1 1272w" sizes="(max-width: 308px) 100vw, 308px" data-recalc-dims="1" /><figcaption id="caption-attachment-195259" class="wp-caption-text">Swami Chetananda worships his dead guru. An excellent example to his students, who are likewise encouraged to worship their living guru.</figcaption></figure>
<div class="public-DraftStyleDefault-block public-DraftStyleDefault-ltr" data-offset-key="6bboe-0-0">
<figure id="attachment_189879" aria-describedby="caption-attachment-189879" style="width: 289px" class="wp-caption alignnone"><img data-attachment-id="189879" data-permalink="https://frankreport.com/2022/04/11/strangulation-swami-cant-get-hard-without-it/swamilineage/" data-orig-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/swamilineage.jpg?fit=377%2C675&amp;ssl=1" data-orig-size="377,675" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="swami+lineage  rudi" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/swamilineage.jpg?fit=168%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/swamilineage.jpg?fit=377%2C675&amp;ssl=1" loading="lazy" class="wp-image-189879" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/swamilineage.jpg?resize=289%2C516&#038;ssl=1" alt="" width="289" height="516" srcset="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/swamilineage.jpg?resize=168%2C300&amp;ssl=1 168w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/swamilineage.jpg?w=377&amp;ssl=1 377w" sizes="(max-width: 289px) 100vw, 289px" data-recalc-dims="1" /><figcaption id="caption-attachment-189879" class="wp-caption-text">The disciplic succession. Nityananda to Rudi to Chetananda.</figcaption></figure>
</div>
</div>
</div>
</div>
</div>
<div data-offset-key="6bboe-0-0">
<p>Shoemaker succeeded in taking over Rudi&#8217;s legacy. Still, he lacked something that would give him the credentials to make money and have sex without having to seduce women. His online bio explains, &#8220;Swamiji formalized his commitment to spiritual growth by being initiated as a swami (&#8216;master of oneself&#8217;) by Swami Muktananda on May 14, 1978.</p>
<p>He took the name Chetanananda, which means &#8216;bliss of pure Self-awareness.'&#8221;Swami Muktananda, like Rudi, was another great master at using the guru-technique to have sex with disciples. A skinny, homely little man, he preferred women and girls. He almost got into serious trouble because the girls he enjoyed best were barely post-pubescent. He liked to finger them at age 12 or 13 to check their purity.</p>
</div>
<p><img data-attachment-id="193191" data-permalink="https://frankreport.com/2022/05/07/two-swamis-muktananda-raped-women-and-girls-but-strangling-is-shoemakers-arena-alone/muktananda/" data-orig-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/muktananda.jpg?fit=570%2C692&amp;ssl=1" data-orig-size="570,692" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="muktananda" data-image-description="" data-image-caption="&lt;p&gt;Swami Muktananda gave Michael Shoemaker the title of Swami and Shoemaker used it well.  He may have even surpassed his guru Muktananda in women he had sex with. Though likely Muktananda&#8217;s record for having sex with teen girls will likely never be broken &#8211; not with new laws and harsher law enforcement.    &lt;/p&gt;
" data-medium-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/muktananda.jpg?fit=247%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/muktananda.jpg?fit=570%2C692&amp;ssl=1" loading="lazy" class=" wp-image-193191" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/muktananda.jpg?resize=572%2C694&#038;ssl=1" alt="" width="572" height="694" srcset="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/muktananda.jpg?resize=247%2C300&amp;ssl=1 247w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/muktananda.jpg?w=570&amp;ssl=1 570w" sizes="(max-width: 572px) 100vw, 572px" data-recalc-dims="1" /></p>
<p>Swami Muktananda gave Michael Shoemaker the title of Swami, and Shoemaker used the title to his advantage. As Swami Chetananda, he may have even surpassed his guru Muktananda in the number of women disciples he had sex with. But in one department, the old master will not likely be topped.</p>
<p>Muktananda&#8217;s record for having sex with teen girls will probably never be broken. With new laws, harsh law enforcement, and penalties for statutory rape, the great gurus have lost one of the most important fields for recruitment. Highly elevated gurus like Chetananda are increasingly waiting until a girl reaches the age of consent before offering her their highly advanced, if at times flaccid, wisdom.</p>
<div data-offset-key="6bboe-0-0"></div>
<div data-offset-key="6bboe-0-0"><img data-attachment-id="195344" data-permalink="https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/chet-swami-iyoung/" data-orig-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-iyoung.jpg?fit=1545%2C1580&amp;ssl=1" data-orig-size="1545,1580" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="chet swami iyoung" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-iyoung.jpg?fit=293%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-iyoung.jpg?fit=1001%2C1024&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-195344" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-iyoung.jpg?resize=293%2C300&#038;ssl=1" alt="" width="293" height="300" srcset="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-iyoung.jpg?resize=293%2C300&amp;ssl=1 293w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-iyoung.jpg?resize=1001%2C1024&amp;ssl=1 1001w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-iyoung.jpg?resize=768%2C785&amp;ssl=1 768w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-iyoung.jpg?resize=1502%2C1536&amp;ssl=1 1502w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-iyoung.jpg?resize=990%2C1012&amp;ssl=1 990w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-iyoung.jpg?resize=1320%2C1350&amp;ssl=1 1320w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-iyoung.jpg?w=1545&amp;ssl=1 1545w" sizes="(max-width: 293px) 100vw, 293px" data-recalc-dims="1" /></div>
<div data-offset-key="6bboe-0-0"></div>
<div data-offset-key="6bboe-0-0">
<p>After Swami Muktananda bestowed on Shoemaker the title Swami, he was known as Swami Chetananda. Once he had the title, he followed in the footsteps of his beloved teachers, Rudi and Muktananda. His destiny was sealed.</p>
</div>
<div data-offset-key="6bboe-0-0"></div>
<div data-offset-key="6bboe-0-0">
<div data-offset-key="6bboe-0-0">
<p>He no longer had to seduce women or get them high on drugs and date rape them. He was their guru and sought only their spiritual welfare. They had to trust him to lead them onward and to higher spiritual pathways.</p>
</div>
</div>
<div data-offset-key="6bboe-0-0"></div>
<div data-offset-key="6bboe-0-0">
<div class="public-DraftStyleDefault-block public-DraftStyleDefault-ltr" data-offset-key="6bboe-0-0">
<p><span data-offset-key="eh1t-0-0">Swami Chetananda&#8217;s biography continues: &#8220;Swami Chetanananda has transformed the lives of thousands of people&#8230;. </span>Swami Chetanananda articulates his wisdom of inner work and spiritual growth in a language and discipline that is practical and appropriate to the needs of his students&#8230;.  As a living example of his teaching, Swamiji is an inspiration, resource, and mentor to people from all walks of life. He is dedicated to facilitating in his students the awakening of the extraordinary experience of their creative potential and nurturing their spiritual growth.&#8221;</p>
</div>
</div>
<div data-offset-key="6bboe-0-0"></div>
<div data-offset-key="6bboe-0-0">
<p>Amen.</p>
</div>
<div data-offset-key="6bboe-0-0"></div>
<div data-offset-key="6bboe-0-0">
<p>Yet, it is often seen in this world that no matter how high-minded a Swami is, there will be some who think poorly of him. Some of his detractors call him Salami Swami. Others call him &#8220;Chet&#8221; behind his back, a disrespectful name for a holy man.</p>
<p>Yet since I started this series, I have received numerous calls and emails. Most of them from women who once accepted Swami Chetananda as their guru. They all tell the same story. He commanded them to have sex with him and sometimes with others.</p>
</div>
<div>
<div class="" data-block="true" data-editor="enka2" data-offset-key="5n0el-0-0">
<div data-offset-key="6bboe-0-0">
<p><img loading="lazy" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/sita-sk.jpg?resize=137%2C157&#038;ssl=1" alt="" width="137" height="157" data-recalc-dims="1" /></p>
<h2>Sita said,</h2>
<p>&#8220;Chet has been at it for more than 40 years. He started out raping women and calling it tantric enlightening. That was 50 years ago. Then ten years later, he showed his really true colors with the sadism. He told me he started the sadism when he was 30. So that is 40-plus years of horrific acts of sadism. He told me that he witnessed a castration. And that was exciting for him. &#8216;Thrilling.&#8217; That is why he loved to use dildos on women&#8217;s anuses. He doesn&#8217;t have much interest in getting close to any vaginas. I think he has some really big fear and hate towards women. Obviously. He forced a dildo into my anus. It was one of the most painful things I have ever felt.&#8221;</p>
<p>Yes, Shoemaker has used the guru-technique for over four decades to have sex with as many as 1000 women.</p>
<p>Before closing, I would like to let readers hear from another woman. I have changed her name to protect her identity. &#8220;Aadya,&#8221; says Shoemaker abused her. She speaks about what he told her and other women.</p>
<p>When Aadya refers to the &#8220;inside,&#8221; she means the ashram [L&#8217;Hermitage] and those who live with him in Gold Beach.</p>
</div>
</div>
</div>
<div data-offset-key="b7dgs-0-0"></div>
<div><img data-attachment-id="194656" data-permalink="https://frankreport.com/2022/05/19/more-intel-on-amazing-swami-who-strangles-beats-and-trains-women-for-gang-bangs/swami-and-nityananda-2/" data-orig-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-and-nityananda-1.jpg?fit=1272%2C1570&amp;ssl=1" data-orig-size="1272,1570" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="swami and nityananda" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-and-nityananda-1.jpg?fit=243%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-and-nityananda-1.jpg?fit=830%2C1024&amp;ssl=1" loading="lazy" class="wp-image-194656" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-and-nityananda-1.jpg?resize=426%2C526&#038;ssl=1" alt="" width="426" height="526" srcset="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-and-nityananda-1.jpg?resize=243%2C300&amp;ssl=1 243w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-and-nityananda-1.jpg?resize=830%2C1024&amp;ssl=1 830w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-and-nityananda-1.jpg?resize=768%2C948&amp;ssl=1 768w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-and-nityananda-1.jpg?resize=1244%2C1536&amp;ssl=1 1244w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-and-nityananda-1.jpg?resize=990%2C1222&amp;ssl=1 990w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-and-nityananda-1.jpg?w=1272&amp;ssl=1 1272w" sizes="(max-width: 426px) 100vw, 426px" data-recalc-dims="1" /></div>
<div>Swami Chetananda in front of a photograph of his guru&#8217;s guru, an Indian named Swami Nityananda.</div>
<div></div>
<div> <img data-attachment-id="195345" data-permalink="https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/che-swamiiii/" data-orig-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/che-swamiiii-.jpg?fit=1500%2C1560&amp;ssl=1" data-orig-size="1500,1560" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="che swamiiii" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/che-swamiiii-.jpg?fit=288%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/che-swamiiii-.jpg?fit=985%2C1024&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-195345" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/che-swamiiii-.jpg?resize=288%2C300&#038;ssl=1" alt="" width="288" height="300" srcset="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/che-swamiiii-.jpg?resize=288%2C300&amp;ssl=1 288w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/che-swamiiii-.jpg?resize=985%2C1024&amp;ssl=1 985w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/che-swamiiii-.jpg?resize=768%2C799&amp;ssl=1 768w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/che-swamiiii-.jpg?resize=1477%2C1536&amp;ssl=1 1477w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/che-swamiiii-.jpg?resize=990%2C1030&amp;ssl=1 990w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/che-swamiiii-.jpg?resize=1320%2C1373&amp;ssl=1 1320w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/che-swamiiii-.jpg?w=1500&amp;ssl=1 1500w" sizes="(max-width: 288px) 100vw, 288px" data-recalc-dims="1" /></div>
<div>A wise and holy man &#8211; Swami Chetananda, follows the ancient tradition of the holy gurus.</div>
<div>
<figure id="attachment_194655" aria-describedby="caption-attachment-194655" style="width: 428px" class="wp-caption alignnone"><img data-attachment-id="194655" data-permalink="https://frankreport.com/2022/05/19/more-intel-on-amazing-swami-who-strangles-beats-and-trains-women-for-gang-bangs/swami-stran-2/" data-orig-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-stran-1.jpg?fit=1230%2C1012&amp;ssl=1" data-orig-size="1230,1012" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="swami stran" data-image-description="" data-image-caption="&lt;p&gt;Swami Chetananda takes a selfie in his exercise room in Gold Beach. &lt;/p&gt;
" data-medium-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-stran-1.jpg?fit=300%2C247&amp;ssl=1" data-large-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-stran-1.jpg?fit=1024%2C843&amp;ssl=1" loading="lazy" class="wp-image-194655" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-stran-1.jpg?resize=428%2C353&#038;ssl=1" alt="" width="428" height="353" srcset="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-stran-1.jpg?resize=300%2C247&amp;ssl=1 300w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-stran-1.jpg?resize=1024%2C843&amp;ssl=1 1024w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-stran-1.jpg?resize=768%2C632&amp;ssl=1 768w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-stran-1.jpg?resize=990%2C815&amp;ssl=1 990w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-stran-1.jpg?w=1230&amp;ssl=1 1230w" sizes="(max-width: 428px) 100vw, 428px" data-recalc-dims="1" /><figcaption id="caption-attachment-194655" class="wp-caption-text">The great Swami takes a selfie in his weight room.</figcaption></figure>
<p><img data-attachment-id="195258" data-permalink="https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/chet-swami-gold-beach/" data-orig-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-gold-beach.jpg?fit=1602%2C1207&amp;ssl=1" data-orig-size="1602,1207" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="chet swami gold beach" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-gold-beach.jpg?fit=300%2C226&amp;ssl=1" data-large-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-gold-beach.jpg?fit=1024%2C772&amp;ssl=1" loading="lazy" class="alignnone wp-image-195258" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-gold-beach.jpg?resize=474%2C357&#038;ssl=1" alt="" width="474" height="357" srcset="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-gold-beach.jpg?resize=300%2C225&amp;ssl=1 300w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-gold-beach.jpg?resize=1024%2C772&amp;ssl=1 1024w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-gold-beach.jpg?resize=768%2C579&amp;ssl=1 768w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-gold-beach.jpg?resize=1536%2C1157&amp;ssl=1 1536w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-gold-beach.jpg?resize=74%2C55&amp;ssl=1 74w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-gold-beach.jpg?resize=111%2C83&amp;ssl=1 111w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-gold-beach.jpg?resize=215%2C161&amp;ssl=1 215w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-gold-beach.jpg?resize=990%2C746&amp;ssl=1 990w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-gold-beach.jpg?resize=1320%2C995&amp;ssl=1 1320w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swami-gold-beach.jpg?w=1602&amp;ssl=1 1602w" sizes="(max-width: 474px) 100vw, 474px" data-recalc-dims="1" /></p>
</div>
<p>The guru business is profitable. The Swami lives in a luxurious residence he calls L&#8217;Hermitage in Gold Beach, Oregon. Free servants who live with him keep the place up and fuck him whenever their spiritual welfare requires it.</p>
<div>
<h2>  <img data-attachment-id="195342" data-permalink="https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/swami-chet-ashram/" data-orig-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-ashram-.jpg?fit=1350%2C1605&amp;ssl=1" data-orig-size="1350,1605" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="swami chet ashram" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-ashram-.jpg?fit=252%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-ashram-.jpg?fit=861%2C1024&amp;ssl=1" loading="lazy" class="alignnone wp-image-195342" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-ashram-.jpg?resize=325%2C387&#038;ssl=1" alt="" width="325" height="387" srcset="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-ashram-.jpg?resize=252%2C300&amp;ssl=1 252w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-ashram-.jpg?resize=861%2C1024&amp;ssl=1 861w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-ashram-.jpg?resize=768%2C913&amp;ssl=1 768w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-ashram-.jpg?resize=1292%2C1536&amp;ssl=1 1292w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-ashram-.jpg?resize=990%2C1177&amp;ssl=1 990w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-ashram-.jpg?resize=1320%2C1569&amp;ssl=1 1320w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-ashram-.jpg?w=1350&amp;ssl=1 1350w" sizes="(max-width: 325px) 100vw, 325px" data-recalc-dims="1" /></h2>
<h2><img data-attachment-id="195343" data-permalink="https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/swami-chet-groupe/" data-orig-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-groupe.jpg?fit=1625%2C1540&amp;ssl=1" data-orig-size="1625,1540" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="swami chet groupe" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-groupe.jpg?fit=300%2C284&amp;ssl=1" data-large-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-groupe.jpg?fit=1024%2C970&amp;ssl=1" loading="lazy" class="alignnone wp-image-195343" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-groupe.jpg?resize=329%2C311&#038;ssl=1" alt="" width="329" height="311" srcset="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-groupe.jpg?resize=300%2C284&amp;ssl=1 300w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-groupe.jpg?resize=1024%2C970&amp;ssl=1 1024w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-groupe.jpg?resize=768%2C728&amp;ssl=1 768w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-groupe.jpg?resize=1536%2C1456&amp;ssl=1 1536w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-groupe.jpg?resize=990%2C938&amp;ssl=1 990w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-groupe.jpg?resize=1320%2C1251&amp;ssl=1 1320w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-groupe.jpg?resize=550%2C520&amp;ssl=1 550w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-groupe.jpg?w=1625&amp;ssl=1 1625w" sizes="(max-width: 329px) 100vw, 329px" data-recalc-dims="1" /></h2>
</div>
<figure id="attachment_195346" aria-describedby="caption-attachment-195346" style="width: 300px" class="wp-caption alignnone"><img data-attachment-id="195346" data-permalink="https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/swami-chet-group3/" data-orig-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-group3.jpg?fit=1642%2C1605&amp;ssl=1" data-orig-size="1642,1605" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="swami chet group3" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-group3.jpg?fit=300%2C293&amp;ssl=1" data-large-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-group3.jpg?fit=1024%2C1001&amp;ssl=1" loading="lazy" class="wp-image-195346 size-medium" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-group3.jpg?resize=300%2C293&#038;ssl=1" alt="" width="300" height="293" srcset="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-group3.jpg?resize=300%2C293&amp;ssl=1 300w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-group3.jpg?resize=1024%2C1001&amp;ssl=1 1024w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-group3.jpg?resize=768%2C751&amp;ssl=1 768w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-group3.jpg?resize=1536%2C1501&amp;ssl=1 1536w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-group3.jpg?resize=990%2C968&amp;ssl=1 990w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-group3.jpg?resize=1320%2C1290&amp;ssl=1 1320w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-group3.jpg?w=1642&amp;ssl=1 1642w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /><figcaption id="caption-attachment-195346" class="wp-caption-text">&#8220;Every day, every day, every day, whether the world is nice to you or mean to you, whatever your experience is, it’s still all about love.&#8221;- Chetananda</figcaption></figure>
<h2></h2>
<h2>A Word From Aadya</h2>
<p><img data-attachment-id="195414" data-permalink="https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/sketch-aadya/" data-orig-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/sketch-aadya.jpg?fit=530%2C590&amp;ssl=1" data-orig-size="530,590" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="sketch aadya" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/sketch-aadya.jpg?fit=269%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/sketch-aadya.jpg?fit=530%2C590&amp;ssl=1" loading="lazy" class="alignnone wp-image-195414" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/sketch-aadya.jpg?resize=170%2C189&#038;ssl=1" alt="" width="170" height="189" srcset="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/sketch-aadya.jpg?resize=269%2C300&amp;ssl=1 269w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/sketch-aadya.jpg?w=530&amp;ssl=1 530w" sizes="(max-width: 170px) 100vw, 170px" data-recalc-dims="1" /></p>
<div>
<h2>By Aadya</h2>
<p><span style="font-size: 16px;">Too many of us who have been on the inside know that everything Frank is reporting is, sadly, completely true and not exaggerated.</span></p>
</div>
<div>
<p>Salami is a master manipulator, a pathological liar, and a very sick, abusive, and mentally ill man.  He promotes himself to be a savior and doctor to all. Instead, he is merely a pervert who calls his own students &#8220;useless animals&#8221; behind their backs or worse. He is a certifiable sociopath and malignant narcissist.</p>
</div>
<div>
<div></div>
</div>
<div>
<p>If you&#8217;re on the inside and don&#8217;t believe it, look up those terms and see who and what you&#8217;ve whored out your soul for.</p>
</div>
<div></div>
<div>
<p>The people who remain by his side do so not out of love but in fear. They&#8217;ve accepted their own enslavement and conditioning because he&#8217;s made them so afraid of the world &#8220;out there.&#8221;</p>
</div>
<div></div>
<div>He preaches to &#8220;love life,&#8221; but lives with his head in his iPad, chatrooms, cocaine, meth, and porn binges, or up his own ass. While he preaches the virtues of &#8220;living a big life&#8221;, those on the inside fear stepping outside of the tiny prison he has carved out for them in his house and in their minds.</div>
<div></div>
<div>
<h2><img data-attachment-id="195350" data-permalink="https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/swami-chet-group-56/" data-orig-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-group-56.jpg?fit=1605%2C1615&amp;ssl=1" data-orig-size="1605,1615" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="swami chet group 56" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-group-56.jpg?fit=298%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-group-56.jpg?fit=1018%2C1024&amp;ssl=1" loading="lazy" class="alignnone wp-image-195350" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-group-56.jpg?resize=402%2C405&#038;ssl=1" alt="" width="402" height="405" srcset="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-group-56.jpg?resize=298%2C300&amp;ssl=1 298w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-group-56.jpg?resize=1018%2C1024&amp;ssl=1 1018w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-group-56.jpg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-group-56.jpg?resize=768%2C773&amp;ssl=1 768w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-group-56.jpg?resize=1526%2C1536&amp;ssl=1 1526w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-group-56.jpg?resize=990%2C996&amp;ssl=1 990w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-group-56.jpg?resize=1320%2C1328&amp;ssl=1 1320w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-group-56.jpg?w=1605&amp;ssl=1 1605w" sizes="(max-width: 402px) 100vw, 402px" data-recalc-dims="1" /></h2>
</div>
<div></div>
<div>
<p>He believes that the highest service a woman can offer this world is her total debasement and enslavement to him and whore herself out to the poor homeless men in town in his name.</p>
</div>
<div></div>
<div>
<p>He believes this is the greatest wish of these poor men come true and that this is great compassion to the less fortunate: A woman who (pretends to) want to have sex with them. The blatant disclosure of his own emotional underdevelopment is astounding.</p>
</div>
<div></div>
<div>
<p>Even if &#8220;good work&#8221; was being done by him and his sex slaves for humankind – you would think he would be very caring and considerate about who and how he &#8220;initiates&#8221; into such &#8220;tantric&#8221; work.</p>
</div>
<div></div>
<div>
<p>He couldn&#8217;t care less how many women&#8217;s lives he destroyed to provide homeless men somewhere to cum on for his own thrill. In fact, the younger, more insecure, self-doubting, or underdeveloped the woman is, the less capable she is of expressing or understanding herself and her needs, the more interested he is in her.</p>
</div>
<div></div>
<div>The easier to control, abuse, and manipulate – and the easier to discredit when he throws them away.</div>
<div></div>
<div><img data-attachment-id="195349" data-permalink="https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/swami-chet-quote/" data-orig-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-quote.jpg?fit=1617%2C1690&amp;ssl=1" data-orig-size="1617,1690" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="swami chet quote" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-quote.jpg?fit=287%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-quote.jpg?fit=980%2C1024&amp;ssl=1" loading="lazy" class="alignnone size-medium wp-image-195349" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-quote.jpg?resize=287%2C300&#038;ssl=1" alt="" width="287" height="300" srcset="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-quote.jpg?resize=287%2C300&amp;ssl=1 287w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-quote.jpg?resize=980%2C1024&amp;ssl=1 980w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-quote.jpg?resize=768%2C803&amp;ssl=1 768w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-quote.jpg?resize=1470%2C1536&amp;ssl=1 1470w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-quote.jpg?resize=990%2C1035&amp;ssl=1 990w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-quote.jpg?resize=1320%2C1380&amp;ssl=1 1320w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/swami-chet-quote.jpg?w=1617&amp;ssl=1 1617w" sizes="(max-width: 287px) 100vw, 287px" data-recalc-dims="1" /></div>
<div></div>
<div>
<p>He just needs somewhere to shove his dick and manipulative delusional claws into so that he can continue feeling important.</p>
</div>
<div></div>
<div>
<p>This organization has been a front to provide an endless source of these young women for him for decades. This organization has only ever continued to eat itself from the inside from its inception, a culture which Salami continues to encourage – pitting everyone into ill spirits against each other. If this organization really existed for the good of humankind, it would have had a completely different M.O. The fact is they all hate themselves. They hate each other, which is how he likes it.</p>
</div>
<div></div>
<div>
<figure id="attachment_195347" aria-describedby="caption-attachment-195347" style="width: 474px" class="wp-caption alignnone"><img data-attachment-id="195347" data-permalink="https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/chet-swamiji/" data-orig-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swamiji.jpg?fit=1550%2C1485&amp;ssl=1" data-orig-size="1550,1485" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="chet swamiji" data-image-description="" data-image-caption="&lt;p&gt;we are permeated by love and unimaginable possibility. Our bodies are love.  Our minds and our senses are love.  All the activity—all the activity that distracts us, pulls our attention, grabs our mind, takes us round the block and makes us think things like “good” and “bad,” “better” and “worse” –even all that activity is love. Meditation is about love. It’s about reaching into our self and making contact with our hearts. And, then holding our awareness there long enough that our heart can start to inform our brain about the unimaginable possibility and power that is inside us. Our heart will tell us that our lives are love.&lt;/p&gt;
" data-medium-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swamiji.jpg?fit=300%2C287&amp;ssl=1" data-large-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swamiji.jpg?fit=1024%2C981&amp;ssl=1" loading="lazy" class=" wp-image-195347" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swamiji.jpg?resize=474%2C453&#038;ssl=1" alt="" width="474" height="453" srcset="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swamiji.jpg?resize=300%2C287&amp;ssl=1 300w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swamiji.jpg?resize=1024%2C981&amp;ssl=1 1024w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swamiji.jpg?resize=768%2C736&amp;ssl=1 768w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swamiji.jpg?resize=1536%2C1472&amp;ssl=1 1536w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swamiji.jpg?resize=990%2C948&amp;ssl=1 990w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swamiji.jpg?resize=1320%2C1265&amp;ssl=1 1320w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-swamiji.jpg?w=1550&amp;ssl=1 1550w" sizes="(max-width: 474px) 100vw, 474px" data-recalc-dims="1" /><figcaption id="caption-attachment-195347" class="wp-caption-text">&#8220;We are permeated by love and unimaginable possibility. Our bodies are love. Our minds and our senses are love. All the activity—all the activity that distracts us, pulls our attention, grabs our mind, takes us round the block and makes us think things like “good” and “bad,” “better” and “worse” –even all that activity is love. Meditation is about love. It’s about reaching into our self and making contact with our hearts. And, then holding our awareness there long enough that our heart can start to inform our brain about the unimaginable possibility and power that is inside us. Our heart will tell us that our lives are love.&#8221;- Swami Chetananda</figcaption></figure>
</div>
<h1>Other Frank Report Stories on the Ri-Bald Swami</h1>
<article class="herald-lay-b post-195043 post type-post status-publish format-standard has-post-thumbnail hentry category-general">
<div class="row">
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="herald-post-thumbnail herald-format-icon-middle"><a title="Swami Chetananda Settled Sex Abuse Lawsuits With Cash and NDAs" href="https://frankreport.com/2022/05/22/swami-chetananda-settled-sex-abuse-lawsuits-with-cash-and-ndas/"><img loading="lazy" class="attachment-herald-lay-b1 size-herald-lay-b1 wp-post-image" style="box-sizing: border-box; vertical-align: middle; max-width: 100%; height: auto; border: 0px;" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-2.jpg?resize=300%2C200&amp;ssl=1" sizes="(max-width: 300px) 100vw, 300px" srcset="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-2.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-2.jpg?resize=414%2C276&amp;ssl=1 414w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-2.jpg?resize=470%2C313&amp;ssl=1 470w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-2.jpg?resize=640%2C426&amp;ssl=1 640w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-2.jpg?resize=130%2C86&amp;ssl=1 130w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-2.jpg?resize=187%2C124&amp;ssl=1 187w" alt="" width="300" height="200" data-attachment-id="195055" data-permalink="https://frankreport.com/2022/05/22/swami-chetananda-settled-sex-abuse-lawsuits-with-cash-and-ndas/chet-2/" data-orig-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-2.jpg?fit=797%2C717&amp;ssl=1" data-orig-size="797,717" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="chet 2" data-image-description="" data-image-caption="&lt;p&gt;Swami Chetananda&lt;/p&gt; " data-medium-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-2.jpg?fit=300%2C270&amp;ssl=1" data-large-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/chet-2.jpg?fit=797%2C717&amp;ssl=1" /></a></div>
</div>
<div class="col-lg-8 col-md-8 col-sm-8">
<div class="entry-header">
<h2 class="entry-title h3"><a href="https://frankreport.com/2022/05/22/swami-chetananda-settled-sex-abuse-lawsuits-with-cash-and-ndas/">Swami Chetananda Settled Sex Abuse Lawsuits With Cash and NDAs</a></h2>
<div class="entry-meta">
<div class="meta-item herald-author"></div>
</div>
</div>
</div>
</div>
</article>
<article class="herald-lay-b post-194705 post type-post status-publish format-standard has-post-thumbnail hentry category-general">
<div class="row">
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="herald-post-thumbnail herald-format-icon-middle"><a title="Magoo: Students Consent to Joyful Sex With Kinky Swami" href="https://frankreport.com/2022/05/20/magoo-students-consent-to-joyful-sex-with-kinky-swami/"><img loading="lazy" class="attachment-herald-lay-b1 size-herald-lay-b1 wp-post-image" style="box-sizing: border-box; vertical-align: middle; max-width: 100%; height: auto; border: 0px;" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/shoemaker-floating.jpg?resize=300%2C200&amp;ssl=1" sizes="(max-width: 300px) 100vw, 300px" srcset="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/shoemaker-floating.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/shoemaker-floating.jpg?resize=414%2C276&amp;ssl=1 414w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/shoemaker-floating.jpg?resize=470%2C313&amp;ssl=1 470w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/shoemaker-floating.jpg?resize=130%2C86&amp;ssl=1 130w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/shoemaker-floating.jpg?resize=187%2C124&amp;ssl=1 187w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/shoemaker-floating.jpg?zoom=2&amp;resize=300%2C200&amp;ssl=1 600w" alt="" width="300" height="200" data-attachment-id="193190" data-permalink="https://frankreport.com/2022/05/07/two-swamis-muktananda-raped-women-and-girls-but-strangling-is-shoemakers-arena-alone/shoemaker-floating/" data-orig-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/shoemaker-floating.jpg?fit=610%2C750&amp;ssl=1" data-orig-size="610,750" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="shoemaker floating" data-image-description="" data-image-caption="&lt;p&gt;A portrait of Michael Shoemaker AKA Swami Chetananda levitating&lt;/p&gt; " data-medium-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/shoemaker-floating.jpg?fit=244%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/shoemaker-floating.jpg?fit=610%2C750&amp;ssl=1" /></a></div>
</div>
<div class="col-lg-8 col-md-8 col-sm-8">
<div class="entry-header">
<h2 class="entry-title h3"><a href="https://frankreport.com/2022/05/20/magoo-students-consent-to-joyful-sex-with-kinky-swami/">Magoo: Students Consent to Joyful Sex With Kinky Swami</a></h2>
<div class="entry-meta"></div>
</div>
<div class="entry-content">
<p>&nbsp;</p>
</div>
</div>
</div>
</article>
<article class="herald-lay-b post-194630 post type-post status-publish format-standard has-post-thumbnail hentry category-general">
<div class="row">
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="herald-post-thumbnail herald-format-icon-middle"><a title="More Intel on Amazing Swami Who Strangles, Beats and Trains Women for Gang-Bangs" href="https://frankreport.com/2022/05/19/more-intel-on-amazing-swami-who-strangles-beats-and-trains-women-for-gang-bangs/"><img loading="lazy" class="attachment-herald-lay-b1 wp-post-image" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/holy-man-shoemaker-swami.jpg?resize=300%2C200&amp;ssl=1" sizes="(max-width: 300px) 100vw, 300px" srcset="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/holy-man-shoemaker-swami.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/holy-man-shoemaker-swami.jpg?resize=414%2C276&amp;ssl=1 414w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/holy-man-shoemaker-swami.jpg?resize=470%2C313&amp;ssl=1 470w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/holy-man-shoemaker-swami.jpg?resize=640%2C426&amp;ssl=1 640w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/holy-man-shoemaker-swami.jpg?resize=130%2C86&amp;ssl=1 130w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/holy-man-shoemaker-swami.jpg?resize=187%2C124&amp;ssl=1 187w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/holy-man-shoemaker-swami.jpg?zoom=3&amp;resize=300%2C200&amp;ssl=1 900w" alt="" width="354" height="236" data-attachment-id="194664" data-permalink="https://frankreport.com/2022/05/19/more-intel-on-amazing-swami-who-strangles-beats-and-trains-women-for-gang-bangs/holy-man-shoemaker-swami/" data-orig-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/holy-man-shoemaker-swami.jpg?fit=1200%2C1157&amp;ssl=1" data-orig-size="1200,1157" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="holy man shoemaker swami" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/holy-man-shoemaker-swami.jpg?fit=300%2C289&amp;ssl=1" data-large-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/holy-man-shoemaker-swami.jpg?fit=1024%2C987&amp;ssl=1" /></a></div>
</div>
<div class="col-lg-8 col-md-8 col-sm-8">
<div class="entry-header">
<h2 class="entry-title h3"><a href="https://frankreport.com/2022/05/19/more-intel-on-amazing-swami-who-strangles-beats-and-trains-women-for-gang-bangs/">More Intel on Amazing Swami Who Strangles, Beats and Trains Women for Gang-Bangs</a></h2>
<div class="entry-meta"></div>
</div>
<div class="entry-content">
<p><a title="Bat-Wielding Swami Sent Woman to Gang-Bang" href="https://frankreport.com/2022/05/17/bat-wielding-swami-sent-woman-to-gang-bang/"><img loading="lazy" class="attachment-herald-lay-b1 size-herald-lay-b1 wp-post-image" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/slugger-swami.jpg?resize=300%2C200&amp;ssl=1" sizes="(max-width: 300px) 100vw, 300px" srcset="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/slugger-swami.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/slugger-swami.jpg?resize=414%2C276&amp;ssl=1 414w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/slugger-swami.jpg?resize=470%2C313&amp;ssl=1 470w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/slugger-swami.jpg?resize=640%2C426&amp;ssl=1 640w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/slugger-swami.jpg?resize=130%2C86&amp;ssl=1 130w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/slugger-swami.jpg?resize=187%2C124&amp;ssl=1 187w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/slugger-swami.jpg?zoom=3&amp;resize=300%2C200&amp;ssl=1 900w" alt="" width="300" height="200" data-attachment-id="194456" data-permalink="https://frankreport.com/2022/05/17/bat-wielding-swami-sent-woman-to-gang-bang/slugger-swami/" data-orig-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/slugger-swami.jpg?fit=1715%2C1225&amp;ssl=1" data-orig-size="1715,1225" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="slugger swami" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/slugger-swami.jpg?fit=300%2C214&amp;ssl=1" data-large-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/slugger-swami.jpg?fit=1024%2C731&amp;ssl=1" /></a></p>
</div>
</div>
</div>
</article>
<article class="herald-lay-b post-194373 post type-post status-publish format-standard has-post-thumbnail hentry category-general">
<div class="row">
<div class="col-lg-8 col-md-8 col-sm-8">
<div class="entry-header">
<h2 class="entry-title h3"><a href="https://frankreport.com/2022/05/17/bat-wielding-swami-sent-woman-to-gang-bang/">Bat-Wielding Swami Sent Woman to Gang-Bang</a></h2>
<div class="entry-meta"></div>
</div>
<div class="entry-content">
<p><a title="Two Swamis –Muktananda Raped Women and Girls; but Strangling is Shoemaker’s Arena Alone" href="https://frankreport.com/2022/05/07/two-swamis-muktananda-raped-women-and-girls-but-strangling-is-shoemakers-arena-alone/"><img loading="lazy" class="attachment-herald-lay-b1 size-herald-lay-b1 wp-post-image" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/bogus-swami-mukt-shoemaker.jpg?resize=300%2C200&amp;ssl=1" sizes="(max-width: 300px) 100vw, 300px" srcset="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/bogus-swami-mukt-shoemaker.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/bogus-swami-mukt-shoemaker.jpg?resize=414%2C276&amp;ssl=1 414w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/bogus-swami-mukt-shoemaker.jpg?resize=470%2C313&amp;ssl=1 470w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/bogus-swami-mukt-shoemaker.jpg?resize=130%2C86&amp;ssl=1 130w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/bogus-swami-mukt-shoemaker.jpg?resize=187%2C124&amp;ssl=1 187w" alt="" width="300" height="200" data-attachment-id="193440" data-permalink="https://frankreport.com/2022/05/07/two-swamis-muktananda-raped-women-and-girls-but-strangling-is-shoemakers-arena-alone/bogus-swami-mukt-shoemaker/" data-orig-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/bogus-swami-mukt-shoemaker.jpg?fit=582%2C507&amp;ssl=1" data-orig-size="582,507" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="bogus swami mukt shoemaker" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/bogus-swami-mukt-shoemaker.jpg?fit=300%2C261&amp;ssl=1" data-large-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/05/bogus-swami-mukt-shoemaker.jpg?fit=582%2C507&amp;ssl=1" /></a></p>
</div>
</div>
</div>
</article>
<article class="herald-lay-b post-190012 post type-post status-publish format-standard has-post-thumbnail hentry category-general">
<div class="row">
<div class="col-lg-8 col-md-8 col-sm-8">
<div class="entry-header">
<h2 class="entry-title h3"><a href="https://frankreport.com/2022/05/07/two-swamis-muktananda-raped-women-and-girls-but-strangling-is-shoemakers-arena-alone/">Two Swamis –Muktananda Raped Women and Girls; but Strangling is Shoemaker’s Arena Alone</a></h2>
<div class="entry-meta"></div>
</div>
</div>
</div>
</article>
<article class="herald-lay-b post-189866 post type-post status-publish format-standard has-post-thumbnail hentry category-general">
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="col-lg-4 col-md-4 col-sm-4">
<div class="herald-post-thumbnail herald-format-icon-middle"><a title="Strangulation Swami Can’t Get Hard Without It" href="https://frankreport.com/2022/04/11/strangulation-swami-cant-get-hard-without-it/"><img loading="lazy" class="attachment-herald-lay-b1 size-herald-lay-b1 wp-post-image alignnone" style="box-sizing: border-box; vertical-align: middle; max-width: 100%; height: auto; border: 0px;" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/shoemaker.jpg?resize=300%2C200&amp;ssl=1" sizes="(max-width: 300px) 100vw, 300px" srcset="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/shoemaker.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/shoemaker.jpg?resize=414%2C276&amp;ssl=1 414w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/shoemaker.jpg?resize=470%2C313&amp;ssl=1 470w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/shoemaker.jpg?resize=640%2C426&amp;ssl=1 640w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/shoemaker.jpg?resize=130%2C86&amp;ssl=1 130w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/shoemaker.jpg?resize=187%2C124&amp;ssl=1 187w, https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/shoemaker.jpg?zoom=3&amp;resize=300%2C200&amp;ssl=1 900w" alt="" width="300" height="200" data-attachment-id="189882" data-permalink="https://frankreport.com/2022/04/11/strangulation-swami-cant-get-hard-without-it/shoemaker/" data-orig-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/shoemaker.jpg?fit=960%2C1040&amp;ssl=1" data-orig-size="960,1040" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="shoemaker" data-image-description="" data-image-caption="&lt;p&gt;The strangulation Swami- J. Michael Shoemaker.&lt;/p&gt; " data-medium-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/shoemaker.jpg?fit=277%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2022/04/shoemaker.jpg?fit=945%2C1024&amp;ssl=1" /></a></div>
</div>
<div class="col-lg-8 col-md-8 col-sm-8">
<div class="entry-header">
<h2 class="entry-title h3" style="text-align: left;"><a href="https://frankreport.com/2022/04/11/strangulation-swami-cant-get-hard-without-it/">Strangulation Swami Can’t Get Hard Without It</a></h2>
<div class="entry-meta" style="text-align: left;"></div>
</div>
<div class="entry-content">
<p>&nbsp;</p>
</div>
</div>
</div>
</article>
<div class="saboxplugin-wrap" itemtype="http://schema.org/Person" itemscope itemprop="author"><div class="saboxplugin-tab"><div class="saboxplugin-gravatar"><img src="https://i0.wp.com/frankreport.com/wp-content/uploads/2021/10/FRANK-REPORT_LOGO_FINAL_B-on-G.jpg?resize=100%2C100&#038;ssl=1" width="100"  height="100" alt="" itemprop="image" data-recalc-dims="1"></div><div class="saboxplugin-authorname"><a href="https://frankreport.com/author/frankparlato/" class="vcard author" rel="author" itemprop="url"><span class="fn" itemprop="name">Frank Parlato</span></a></div><div class="saboxplugin-desc"><div itemprop="description"></div></div><div class="clearfix"></div></div></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-195194" class="share-twitter sd-button share-icon" href="https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-195194" class="share-facebook sd-button share-icon" href="https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon" href="https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-end"></li></ul></div></div></div>
	
	
				</div>			</div>

			<div id="extras" class="col-lg-12 col-md-12 col-sm-12">
				
	<div id="author" class="herald-vertical-padding">
	<div class="herald-mod-wrap"><div class="herald-mod-head "><div class="herald-mod-title"><h4 class="h6 herald-mod-h herald-color">About the author</h4></div><div class="herald-mod-actions"><a href="https://frankreport.com/author/frankparlato/">View All Posts</a></div></div></div>
	<div class="herald-author row">

		<div class="herald-author-data col-lg-2 col-md-2 col-sm-2 col-xs-2">
			<img alt='' src='https://frankreport.com/wp-content/uploads/2021/10/FRANK-REPORT_LOGO_FINAL_B-on-G.jpg' srcset='https://frankreport.com/wp-content/uploads/2021/10/FRANK-REPORT_LOGO_FINAL_B-on-G.jpg 2x' class='avatar avatar-140 photo sab-custom-avatar' height='140' width='140' />		</div>
		
		<div class="herald-data-content col-lg-10 col-md-10 col-sm-10 col-xs-10">
			<h4 class="author-title">Frank Parlato</h4>
					</div>

	</div>


</div>
	

	<div id="comments" class="herald-comments">

		<div class="herald-mod-wrap"><div class="herald-mod-head "><div class="herald-mod-title"><h4 class="h6 herald-mod-h herald-color">Add Comment</h4></div></div></div>		
					<div class="herald-gray-area"><span class="herald-fake-button herald-comment-form-open">Click here to post a comment</span></div>



		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Please leave a comment: Your opinion is important to us! (Email &amp; username are optional)					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe
					title="Comment Form"
					src="https://jetpack.wordpress.com/jetpack-comment/?blogid=103448067&#038;postid=195194&#038;comment_registration=0&#038;require_name_email=0&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=identicon&#038;greeting=Please+leave+a+comment%3A+Your+opinion+is+important+to+us%21+%28Email+%26+username+are+optional%29&#038;jetpack_comments_nonce=100e61571d&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=11.0-a.9&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=714ce134062451447324bbdd529e4941725bb8e9#parent=https%3A%2F%2Ffrankreport.com%2F2022%2F05%2F24%2Fswami-chetananda-demanded-female-disciples-pity-f-k-homeless-men%2F"
											name="jetpack_remote_comment"
						style="width:100%; height: 430px; border:0;"
										class="jetpack_remote_comment"
					id="jetpack_remote_comment"
					sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"
				>
									</iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

				
		
		
	</div>


	<div id="single-sticky" class="herald-single-sticky herald-single-wraper hidden-xs hidden-sm">
	<div class="container">
		<div class="row">
			<div class="col-lg-12 col-md-12">
				
									
					
										

					
											<div class="herald-sticky-next h6">
							<a href="https://frankreport.com/2022/05/23/erika-durance-didnt-like-allison-mack-short-new-interpretive-book-allison-published/" rel="prev">Erika Durance Didn&#8217;t Like Allison Mack &#038; Short, New Interpretive Book &#8216;Allison&#8217; Published</a>						</div>
					
				
					<div class="herald-sticky-share">
						
						
						<a href="https://frankreport.com/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/#respond" class="herald-comment-action" >Comment</a>						
						
													

	<ul class="herald-share">
		<span class="herald-share-meta"><i class="fa fa-share-alt"></i>Share This!</span>
		<div class="meta-share-wrapper">
						     <li class="facebook"> <a href="javascript:void(0);" data-url="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Ffrankreport.com%2F2022%2F05%2F24%2Fswami-chetananda-demanded-female-disciples-pity-f-k-homeless-men%2F&amp;t=Swami+Chetananda+Demanded+Female+Disciples+Pity+F%26%238212%3Bk+Homeless+Men"><i class="fa fa-facebook"></i><span>Facebook</span></a> </li>
						     <li class="twitter"> <a href="javascript:void(0);" data-url="http://twitter.com/intent/tweet?url=https%3A%2F%2Ffrankreport.com%2F2022%2F05%2F24%2Fswami-chetananda-demanded-female-disciples-pity-f-k-homeless-men%2F&amp;text=Swami+Chetananda+Demanded+Female+Disciples+Pity+F%26%238212%3Bk+Homeless+Men"><i class="fa fa-twitter"></i><span>Twitter</span></a> </li>
						     <li class="pinterest"> <a href="javascript:void(0);" data-url="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Ffrankreport.com%2F2022%2F05%2F24%2Fswami-chetananda-demanded-female-disciples-pity-f-k-homeless-men%2F&amp;media=https%3A%2F%2Fi0.wp.com%2Ffrankreport.com%2Fwp-content%2Fuploads%2F2022%2F05%2Fswami-beast-2.jpg%3Ffit%3D910%252C1260%26amp%3Bssl%3D1&amp;description=Swami+Chetananda+Demanded+Female+Disciples+Pity+F%26%238212%3Bk+Homeless+Men"><i class="fa fa-pinterest"></i><span>Pinterest</span></a> </li>
						     <li class="linkedin"> <a href="javascript:void(0);" data-url="http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Ffrankreport.com%2F2022%2F05%2F24%2Fswami-chetananda-demanded-female-disciples-pity-f-k-homeless-men%2F&amp;title=Swami+Chetananda+Demanded+Female+Disciples+Pity+F%26%238212%3Bk+Homeless+Men"><i class="fa fa-linkedin"></i><span>LinkedIn</span></a> </li>
				 	</div>
	</ul>

						
					</div>

			</div>
		</div>
	</div>					
</div>			</div>

		</div>

</div>

	

	<div class="herald-sidebar col-lg-3 col-md-3 herald-sidebar-right">

					<div id="media_image-4" class="widget widget_media_image"><style>.widget.widget_media_image img { height: auto; max-width: 100%; } </style><figure style="width: 300px" class="wp-caption alignnone"><img width="300" height="213" src="https://i0.wp.com/frankreport.com/wp-content/uploads/2021/10/0.jpg?fit=300%2C213&amp;ssl=1" class="image wp-image-176961  attachment-medium size-medium" alt="" loading="lazy" style="max-width: 100%; height: auto;" srcset="https://i0.wp.com/frankreport.com/wp-content/uploads/2021/10/0.jpg?w=507&amp;ssl=1 507w, https://i0.wp.com/frankreport.com/wp-content/uploads/2021/10/0.jpg?resize=300%2C213&amp;ssl=1 300w" sizes="(max-width: 300px) 100vw, 300px" data-attachment-id="176961" data-permalink="https://frankreport.com/2021/10/28/glazer-accuses-suneel-in-nxivm-civil-lawsuit-hearing-and-suneels-rebuttal/frank-parlato-dateline-photo/" data-orig-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2021/10/0.jpg?fit=507%2C360&amp;ssl=1" data-orig-size="507,360" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="frank parlato dateline photo" data-image-description="" data-image-caption="&lt;p&gt;Frank Parlato, as he looks into the distance and comes up with new and exciting ways to distract his readers from the facts at hand.&lt;/p&gt;
" data-medium-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2021/10/0.jpg?fit=300%2C213&amp;ssl=1" data-large-file="https://i0.wp.com/frankreport.com/wp-content/uploads/2021/10/0.jpg?fit=507%2C360&amp;ssl=1" /><figcaption class="wp-caption-text">Frank Parlato</figcaption></figure></div><div id="text-4" class="widget widget_text"><h4 class="widget-title h6"><span>About the Author</span></h4>			<div class="textwidget"><p>Frank Parlato is an investigative journalist.</p>
<p>His work has been cited in hundreds of news outlets, like The New York Times, The Daily Mail, VICE News, CBS News, Fox News, New York Post, New York Daily News, Oxygen, Rolling Stone, People Magazine, The Sun, The Times of London, CBS Inside Edition, among many others in all five continents.</p>
<p>His work to expose and take down NXIVM is featured in books like “Captive” by Catherine Oxenberg, “Scarred” by Sarah Edmonson, “The Program” by Toni Natalie, and “NXIVM. La Secta Que Sedujo al Poder en México” by Juan Alberto Vasquez.</p>
<p>Parlato has been prominently featured on HBO’s docuseries “The Vow” and was the lead investigator and coordinating producer for Investigation Discovery’s “The Lost Women of NXIVM.” In addition, he was credited in the Starz docuseries 'Seduced' for saving 'slave' women from being branded and escaping the sex-slave cult known as DOS.</p>
<p>Parlato appeared on the Nancy Grace Show, Beyond the Headlines with Gretchen Carlson, Dr. Oz, American Greed, Dateline NBC, and NBC Nightly News with Lester Holt, where Parlato conducted the first-ever interview with Keith Raniere after his arrest. This was ironic, as many credit Parlato as one of the primary architects of his arrest and the cratering of the cult he founded.</p>
<p>Parlato is a consulting producer and appears in TNT's The Heiress and the Sex Cult, which premieres on May 22, 2022.</p>
<p>IMDb — Frank Parlato</p>
<p>https://en.wikipedia.org/wiki/Frank_Parlato,_Jr.</p>
<p>Contact Frank with tips or for help.<br />
Phone / Text: (305) 783-7083<br />
Email: frankparlato@gmail.com</p>
</div>
		</div><div id="archives-5" class="widget widget_archive"><h4 class="widget-title h6"><span>Archives</span></h4>		<label class="screen-reader-text" for="archives-dropdown-5">Archives</label>
		<select id="archives-dropdown-5" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://frankreport.com/2022/05/'> May 2022 </option>
	<option value='https://frankreport.com/2022/04/'> April 2022 </option>
	<option value='https://frankreport.com/2022/03/'> March 2022 </option>
	<option value='https://frankreport.com/2022/02/'> February 2022 </option>
	<option value='https://frankreport.com/2022/01/'> January 2022 </option>
	<option value='https://frankreport.com/2021/12/'> December 2021 </option>
	<option value='https://frankreport.com/2021/11/'> November 2021 </option>
	<option value='https://frankreport.com/2021/10/'> October 2021 </option>
	<option value='https://frankreport.com/2021/09/'> September 2021 </option>
	<option value='https://frankreport.com/2021/08/'> August 2021 </option>
	<option value='https://frankreport.com/2021/07/'> July 2021 </option>
	<option value='https://frankreport.com/2021/06/'> June 2021 </option>
	<option value='https://frankreport.com/2021/05/'> May 2021 </option>
	<option value='https://frankreport.com/2021/04/'> April 2021 </option>
	<option value='https://frankreport.com/2021/03/'> March 2021 </option>
	<option value='https://frankreport.com/2021/02/'> February 2021 </option>
	<option value='https://frankreport.com/2021/01/'> January 2021 </option>
	<option value='https://frankreport.com/2020/12/'> December 2020 </option>
	<option value='https://frankreport.com/2020/11/'> November 2020 </option>
	<option value='https://frankreport.com/2020/10/'> October 2020 </option>
	<option value='https://frankreport.com/2020/09/'> September 2020 </option>
	<option value='https://frankreport.com/2020/08/'> August 2020 </option>
	<option value='https://frankreport.com/2020/07/'> July 2020 </option>
	<option value='https://frankreport.com/2020/06/'> June 2020 </option>
	<option value='https://frankreport.com/2020/05/'> May 2020 </option>
	<option value='https://frankreport.com/2020/04/'> April 2020 </option>
	<option value='https://frankreport.com/2020/03/'> March 2020 </option>
	<option value='https://frankreport.com/2020/02/'> February 2020 </option>
	<option value='https://frankreport.com/2020/01/'> January 2020 </option>
	<option value='https://frankreport.com/2019/12/'> December 2019 </option>
	<option value='https://frankreport.com/2019/11/'> November 2019 </option>
	<option value='https://frankreport.com/2019/10/'> October 2019 </option>
	<option value='https://frankreport.com/2019/09/'> September 2019 </option>
	<option value='https://frankreport.com/2019/08/'> August 2019 </option>
	<option value='https://frankreport.com/2019/07/'> July 2019 </option>
	<option value='https://frankreport.com/2019/06/'> June 2019 </option>
	<option value='https://frankreport.com/2019/05/'> May 2019 </option>
	<option value='https://frankreport.com/2019/04/'> April 2019 </option>
	<option value='https://frankreport.com/2019/03/'> March 2019 </option>
	<option value='https://frankreport.com/2019/02/'> February 2019 </option>
	<option value='https://frankreport.com/2019/01/'> January 2019 </option>
	<option value='https://frankreport.com/2018/12/'> December 2018 </option>
	<option value='https://frankreport.com/2018/11/'> November 2018 </option>
	<option value='https://frankreport.com/2018/10/'> October 2018 </option>
	<option value='https://frankreport.com/2018/09/'> September 2018 </option>
	<option value='https://frankreport.com/2018/08/'> August 2018 </option>
	<option value='https://frankreport.com/2018/07/'> July 2018 </option>
	<option value='https://frankreport.com/2018/06/'> June 2018 </option>
	<option value='https://frankreport.com/2018/05/'> May 2018 </option>
	<option value='https://frankreport.com/2018/04/'> April 2018 </option>
	<option value='https://frankreport.com/2018/03/'> March 2018 </option>
	<option value='https://frankreport.com/2018/02/'> February 2018 </option>
	<option value='https://frankreport.com/2018/01/'> January 2018 </option>
	<option value='https://frankreport.com/2017/12/'> December 2017 </option>
	<option value='https://frankreport.com/2017/11/'> November 2017 </option>
	<option value='https://frankreport.com/2017/10/'> October 2017 </option>
	<option value='https://frankreport.com/2017/09/'> September 2017 </option>
	<option value='https://frankreport.com/2017/08/'> August 2017 </option>
	<option value='https://frankreport.com/2017/07/'> July 2017 </option>
	<option value='https://frankreport.com/2017/06/'> June 2017 </option>
	<option value='https://frankreport.com/2017/03/'> March 2017 </option>
	<option value='https://frankreport.com/2017/02/'> February 2017 </option>
	<option value='https://frankreport.com/2016/12/'> December 2016 </option>
	<option value='https://frankreport.com/2016/02/'> February 2016 </option>
	<option value='https://frankreport.com/2016/01/'> January 2016 </option>
	<option value='https://frankreport.com/2015/12/'> December 2015 </option>
	<option value='https://frankreport.com/2015/11/'> November 2015 </option>

		</select>

<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-5" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
			</div><div id="block-9" class="widget widget_block"><h4 class="widget-title h6"><span>Connect</span></h4><div class="wp-widget-group__inner-blocks">
<div class="wp-container-4 wp-block-group"><div class="wp-block-group__inner-container">
<ul class="wp-container-3 wp-block-social-links has-icon-color has-icon-background-color is-style-default"><li style="color: #ffffff; background-color: #000000; " class="wp-social-link wp-social-link-twitter wp-block-social-link"><a href="https://twitter.com/frank_report"  class="wp-block-social-link-anchor"><svg width="24" height="24" viewBox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" aria-hidden="true" focusable="false"><path d="M22.23,5.924c-0.736,0.326-1.527,0.547-2.357,0.646c0.847-0.508,1.498-1.312,1.804-2.27 c-0.793,0.47-1.671,0.812-2.606,0.996C18.324,4.498,17.257,4,16.077,4c-2.266,0-4.103,1.837-4.103,4.103 c0,0.322,0.036,0.635,0.106,0.935C8.67,8.867,5.647,7.234,3.623,4.751C3.27,5.357,3.067,6.062,3.067,6.814 c0,1.424,0.724,2.679,1.825,3.415c-0.673-0.021-1.305-0.206-1.859-0.513c0,0.017,0,0.034,0,0.052c0,1.988,1.414,3.647,3.292,4.023 c-0.344,0.094-0.707,0.144-1.081,0.144c-0.264,0-0.521-0.026-0.772-0.074c0.522,1.63,2.038,2.816,3.833,2.85 c-1.404,1.1-3.174,1.756-5.096,1.756c-0.331,0-0.658-0.019-0.979-0.057c1.816,1.164,3.973,1.843,6.29,1.843 c7.547,0,11.675-6.252,11.675-11.675c0-0.178-0.004-0.355-0.012-0.531C20.985,7.47,21.68,6.747,22.23,5.924z"></path></svg><span class="wp-block-social-link-label screen-reader-text">Twitter</span></a></li>

<li style="color: #ffffff; background-color: #000000; " class="wp-social-link wp-social-link-facebook wp-block-social-link"><a href="https://www.facebook.com/Frank-Report-113322427466889"  class="wp-block-social-link-anchor"><svg width="24" height="24" viewBox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" aria-hidden="true" focusable="false"><path d="M12 2C6.5 2 2 6.5 2 12c0 5 3.7 9.1 8.4 9.9v-7H7.9V12h2.5V9.8c0-2.5 1.5-3.9 3.8-3.9 1.1 0 2.2.2 2.2.2v2.5h-1.3c-1.2 0-1.6.8-1.6 1.6V12h2.8l-.4 2.9h-2.3v7C18.3 21.1 22 17 22 12c0-5.5-4.5-10-10-10z"></path></svg><span class="wp-block-social-link-label screen-reader-text">Facebook</span></a></li>

<li style="color: #ffffff; background-color: #000000; " class="wp-social-link wp-social-link-chain wp-block-social-link"><a href="https://parler.com/profile/FrankReport/posts"  class="wp-block-social-link-anchor"><svg width="24" height="24" viewBox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" aria-hidden="true" focusable="false"><path d="M19.647,16.706a1.134,1.134,0,0,0-.343-.833l-2.549-2.549a1.134,1.134,0,0,0-.833-.343,1.168,1.168,0,0,0-.883.392l.233.226q.2.189.264.264a2.922,2.922,0,0,1,.184.233.986.986,0,0,1,.159.312,1.242,1.242,0,0,1,.043.337,1.172,1.172,0,0,1-1.176,1.176,1.237,1.237,0,0,1-.337-.043,1,1,0,0,1-.312-.159,2.76,2.76,0,0,1-.233-.184q-.073-.068-.264-.264l-.226-.233a1.19,1.19,0,0,0-.4.895,1.134,1.134,0,0,0,.343.833L15.837,19.3a1.13,1.13,0,0,0,.833.331,1.18,1.18,0,0,0,.833-.318l1.8-1.789a1.12,1.12,0,0,0,.343-.821Zm-8.615-8.64a1.134,1.134,0,0,0-.343-.833L8.163,4.7a1.134,1.134,0,0,0-.833-.343,1.184,1.184,0,0,0-.833.331L4.7,6.473a1.12,1.12,0,0,0-.343.821,1.134,1.134,0,0,0,.343.833l2.549,2.549a1.13,1.13,0,0,0,.833.331,1.184,1.184,0,0,0,.883-.38L8.728,10.4q-.2-.189-.264-.264A2.922,2.922,0,0,1,8.28,9.9a.986.986,0,0,1-.159-.312,1.242,1.242,0,0,1-.043-.337A1.172,1.172,0,0,1,9.254,8.079a1.237,1.237,0,0,1,.337.043,1,1,0,0,1,.312.159,2.761,2.761,0,0,1,.233.184q.073.068.264.264l.226.233a1.19,1.19,0,0,0,.4-.895ZM22,16.706a3.343,3.343,0,0,1-1.042,2.488l-1.8,1.789a3.536,3.536,0,0,1-4.988-.025l-2.525-2.537a3.384,3.384,0,0,1-1.017-2.488,3.448,3.448,0,0,1,1.078-2.561l-1.078-1.078a3.434,3.434,0,0,1-2.549,1.078,3.4,3.4,0,0,1-2.5-1.029L3.029,9.794A3.4,3.4,0,0,1,2,7.294,3.343,3.343,0,0,1,3.042,4.806l1.8-1.789A3.384,3.384,0,0,1,7.331,2a3.357,3.357,0,0,1,2.5,1.042l2.525,2.537a3.384,3.384,0,0,1,1.017,2.488,3.448,3.448,0,0,1-1.078,2.561l1.078,1.078a3.551,3.551,0,0,1,5.049-.049l2.549,2.549A3.4,3.4,0,0,1,22,16.706Z"></path></svg><span class="wp-block-social-link-label screen-reader-text">Link</span></a></li>

<li style="color: #ffffff; background-color: #000000; " class="wp-social-link wp-social-link-linkedin wp-block-social-link"><a href="https://www.linkedin.com/in/frank-parlato-ba8722136/"  class="wp-block-social-link-anchor"><svg width="24" height="24" viewBox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" aria-hidden="true" focusable="false"><path d="M19.7,3H4.3C3.582,3,3,3.582,3,4.3v15.4C3,20.418,3.582,21,4.3,21h15.4c0.718,0,1.3-0.582,1.3-1.3V4.3 C21,3.582,20.418,3,19.7,3z M8.339,18.338H5.667v-8.59h2.672V18.338z M7.004,8.574c-0.857,0-1.549-0.694-1.549-1.548 c0-0.855,0.691-1.548,1.549-1.548c0.854,0,1.547,0.694,1.547,1.548C8.551,7.881,7.858,8.574,7.004,8.574z M18.339,18.338h-2.669 v-4.177c0-0.996-0.017-2.278-1.387-2.278c-1.389,0-1.601,1.086-1.601,2.206v4.249h-2.667v-8.59h2.559v1.174h0.037 c0.356-0.675,1.227-1.387,2.526-1.387c2.703,0,3.203,1.779,3.203,4.092V18.338z"></path></svg><span class="wp-block-social-link-label screen-reader-text">LinkedIn</span></a></li></ul>
</div></div>
</div></div><div id="author_grid-2" class="widget widget_author_grid"><h4 class="widget-title h6"><span>Authors</span></h4><ul><li><a href="https://frankreport.com/author/annamercury/"> <img alt='' src='https://frankreport.com/wp-content/uploads/2022/03/anna-mercury.jpg' srcset='https://frankreport.com/wp-content/uploads/2022/03/anna-mercury.jpg 2x' class='avatar avatar-32 photo sab-custom-avatar' height='32' width='32' /></a></li><li><a href="https://frankreport.com/author/dorian-mcclintock/"> <img alt='' src='https://secure.gravatar.com/avatar/a5c20ec85e31eb3f60308242ef6379c7?s=32&#038;d=identicon&#038;r=g' srcset='https://secure.gravatar.com/avatar/a5c20ec85e31eb3f60308242ef6379c7?s=64&#038;d=identicon&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy'/></a></li><li><a href="https://frankreport.com/author/frank/"> <img alt='' src='https://secure.gravatar.com/avatar/45ccd587ca2ed8158fcc3956718537d2?s=32&#038;d=identicon&#038;r=g' srcset='https://secure.gravatar.com/avatar/45ccd587ca2ed8158fcc3956718537d2?s=64&#038;d=identicon&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy'/></a></li><li><a href="https://frankreport.com/author/frankparlato/"> <img alt='' src='https://frankreport.com/wp-content/uploads/2021/10/FRANK-REPORT_LOGO_FINAL_B-on-G.jpg' srcset='https://frankreport.com/wp-content/uploads/2021/10/FRANK-REPORT_LOGO_FINAL_B-on-G.jpg 2x' class='avatar avatar-32 photo sab-custom-avatar' height='32' width='32' /></a></li><li><a href="https://frankreport.com/author/guest-view/"> <img alt='' src='https://secure.gravatar.com/avatar/50db7729dda7e6442fafbbd17a5c8106?s=32&#038;d=identicon&#038;r=g' srcset='https://secure.gravatar.com/avatar/50db7729dda7e6442fafbbd17a5c8106?s=64&#038;d=identicon&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy'/></a></li><li><a href="https://frankreport.com/author/heidih/"> <img alt='' src='https://secure.gravatar.com/avatar/ec4763d5169744c48b6fae52b2297d1c?s=32&#038;d=identicon&#038;r=g' srcset='https://secure.gravatar.com/avatar/ec4763d5169744c48b6fae52b2297d1c?s=64&#038;d=identicon&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy'/></a></li><li><a href="https://frankreport.com/author/joejohara/"> <img alt='' src='https://frankreport.com/wp-content/uploads/2022/04/Screen-Shot-2022-04-05-at-2.59.10-AM.png' srcset='https://frankreport.com/wp-content/uploads/2022/04/Screen-Shot-2022-04-05-at-2.59.10-AM.png 2x' class='avatar avatar-32 photo sab-custom-avatar' height='32' width='32' /></a></li><li><a href="https://frankreport.com/author/krclaviger/"> <img alt='' src='https://secure.gravatar.com/avatar/6862e4123b7565f2df09fab4399291dd?s=32&#038;d=identicon&#038;r=g' srcset='https://secure.gravatar.com/avatar/6862e4123b7565f2df09fab4399291dd?s=64&#038;d=identicon&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy'/></a></li><li><a href="https://frankreport.com/author/nxivmart/"> <img alt='' src='https://secure.gravatar.com/avatar/0e9caebd642b9e698a7bccb371339529?s=32&#038;d=identicon&#038;r=g' srcset='https://secure.gravatar.com/avatar/0e9caebd642b9e698a7bccb371339529?s=64&#038;d=identicon&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy'/></a></li><li><a href="https://frankreport.com/author/paulserran/"> <img alt='' src='https://secure.gravatar.com/avatar/1291aedc54db8eda664aee5752defff3?s=32&#038;d=identicon&#038;r=g' srcset='https://secure.gravatar.com/avatar/1291aedc54db8eda664aee5752defff3?s=64&#038;d=identicon&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy'/></a></li><li><a href="https://frankreport.com/author/roger-stone/"> <img alt='' src='https://secure.gravatar.com/avatar/4b54f5eea422f7d7a2125177fe5a5f23?s=32&#038;d=identicon&#038;r=g' srcset='https://secure.gravatar.com/avatar/4b54f5eea422f7d7a2125177fe5a5f23?s=64&#038;d=identicon&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy'/></a></li><li><a href="https://frankreport.com/author/suneel-chakravorty/"> <img alt='' src='https://secure.gravatar.com/avatar/03f5f1a5ed39c48108522d6fbed0ecc7?s=32&#038;d=identicon&#038;r=g' srcset='https://secure.gravatar.com/avatar/03f5f1a5ed39c48108522d6fbed0ecc7?s=64&#038;d=identicon&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy'/></a></li></ul></div>		
					<div class="herald-sticky">
				<div id="nav_menu-4" class="widget widget_nav_menu"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-119349" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-119349"><a href="https://frankreport.com/category/general/">General</a></li>
<li id="menu-item-119351" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-119351"><a href="https://frankreport.com/contact/">Contact</a></li>
<li id="menu-item-119352" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-119352"><a href="https://frankreport.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-119353" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-119353"><a href="https://frankreport.com/terms-conditions/">Terms &#038; Conditions</a></li>
</ul></div></div>			</div>
		
	</div>


			</div>	
		</article>
	</div>


	</div>

	
	<footer id="footer" class="herald-site-footer herald-slide">

					
<div class="footer-widgets container">
	<div class="row">
					<div class="col-lg-3 col-md-3 col-sm-3">
							</div>
					<div class="col-lg-3 col-md-3 col-sm-3">
							</div>
					<div class="col-lg-3 col-md-3 col-sm-3">
							</div>
					<div class="col-lg-3 col-md-3 col-sm-3">
							</div>
			</div>
</div>		
					<div class="footer-bottom">
<div class="container">
	<div class="row">
		<div class="col-lg-12">
			
									<div class="hel-l herald-go-hor">
									<div class="herald-copyright">Copyright &copy; 2015-2020 Frank Report.</div>							</div>
			
									<div class="hel-r herald-go-hor">
																</div>
			
						
		</div>
	</div>
</div>
</div>	    
	</footer>

	

<!--  -->
<script defer id='bilmur' data-provider='wordpress.com' data-service='atomic'  src='https://s0.wp.com/wp-content/js/bilmur.min.js?m=202221'></script>
				<style type="text/css">
					.searchwp-live-search-results {
						opacity: 0;
						transition: opacity .25s ease-in-out;
						-moz-transition: opacity .25s ease-in-out;
						-webkit-transition: opacity .25s ease-in-out;
						height: 0;
						overflow: hidden;
						z-index: 9999995; /* Exceed SearchWP Modal Search Form overlay. */
						position: absolute;
						display: none;
					}

					.searchwp-live-search-results-showing {
						display: block;
						opacity: 1;
						height: auto;
						overflow: auto;
					}

					.searchwp-live-search-no-results {
						padding: 3em 2em 0;
						text-align: center;
					}

					.searchwp-live-search-no-min-chars:after {
						content: "Continue typing";
						display: block;
						text-align: center;
						padding: 2em 2em 0;
					}
				</style>
						<script>
			var _SEARCHWP_LIVE_AJAX_SEARCH_BLOCKS = true;
			var _SEARCHWP_LIVE_AJAX_SEARCH_ENGINE = 'default';
			var _SEARCHWP_LIVE_AJAX_SEARCH_CONFIG = 'default';
			</script>
					<div id="jp-carousel-loading-overlay">
			<div id="jp-carousel-loading-wrapper">
				<span id="jp-carousel-library-loading">&nbsp;</span>
			</div>
		</div>
		<div class="jp-carousel-overlay" style="display: none;">

		<div class="jp-carousel-container">
			<!-- The Carousel Swiper -->
			<div
				class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions"
				itemscope
				itemtype="https://schema.org/ImageGallery">
				<div class="jp-carousel swiper-wrapper"></div>
				<div class="jp-swiper-button-prev swiper-button-prev">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12">
							<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskPrev)">
							<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
				<div class="jp-swiper-button-next swiper-button-next">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12">
							<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskNext)">
							<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
			</div>
			<!-- The main close buton -->
			<div class="jp-carousel-close-hint">
				<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
					<mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14">
						<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white"/>
					</mask>
					<g mask="url(#maskClose)">
						<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF"/>
					</g>
				</svg>
			</div>
			<!-- Image info, comments and meta -->
			<div class="jp-carousel-info">
				<div class="jp-carousel-info-footer">
					<div class="jp-carousel-pagination-container">
						<div class="jp-swiper-pagination swiper-pagination"></div>
						<div class="jp-carousel-pagination"></div>
					</div>
					<div class="jp-carousel-photo-title-container">
						<h2 class="jp-carousel-photo-caption"></h2>
					</div>
					<div class="jp-carousel-photo-icons-container">
						<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white"/>
									</mask>
									<g mask="url(#maskInfo)">
										<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
							</span>
						</a>
												<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-comments" aria-label="Toggle photo comments visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskComments" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M4.3271 2H20.2486C21.3432 2 22.2388 2.9 22.2388 4V16C22.2388 17.1 21.3432 18 20.2486 18H6.31729L2.33691 22V4C2.33691 2.9 3.2325 2 4.3271 2ZM6.31729 16H20.2486V4H4.3271V18L6.31729 16Z" fill="white"/>
									</mask>
									<g mask="url(#maskComments)">
										<rect x="0.34668" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>

								<span class="jp-carousel-has-comments-indicator" aria-label="This image has comments."></span>
							</span>
						</a>
											</div>
				</div>
				<div class="jp-carousel-info-extra">
					<div class="jp-carousel-info-content-wrapper">
						<div class="jp-carousel-photo-title-container">
							<h2 class="jp-carousel-photo-title"></h2>
						</div>
						<div class="jp-carousel-comments-wrapper">
															<div id="jp-carousel-comments-loading">
									<span>Loading Comments...</span>
								</div>
								<div class="jp-carousel-comments"></div>
								<div id="jp-carousel-comment-form-container">
									<span id="jp-carousel-comment-form-spinner">&nbsp;</span>
									<div id="jp-carousel-comment-post-results"></div>
																														<form id="jp-carousel-comment-form">
												<label for="jp-carousel-comment-form-comment-field" class="screen-reader-text">Write a Comment...</label>
												<textarea
													name="comment"
													class="jp-carousel-comment-form-field jp-carousel-comment-form-textarea"
													id="jp-carousel-comment-form-comment-field"
													placeholder="Write a Comment..."
												></textarea>
												<div id="jp-carousel-comment-form-submit-and-info-wrapper">
													<div id="jp-carousel-comment-form-commenting-as">
																													<fieldset>
																<label for="jp-carousel-comment-form-email-field">Email</label>
																<input type="text" name="email" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-email-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-author-field">Name</label>
																<input type="text" name="author" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-author-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-url-field">Website</label>
																<input type="text" name="url" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-url-field" />
															</fieldset>
																											</div>
													<input
														type="submit"
														name="submit"
														class="jp-carousel-comment-form-button"
														id="jp-carousel-comment-form-button-submit"
														value="Post Comment" />
												</div>
											</form>
																											</div>
													</div>
						<div class="jp-carousel-image-meta">
							<div class="jp-carousel-title-and-caption">
								<div class="jp-carousel-photo-info">
									<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
								</div>

								<div class="jp-carousel-photo-description"></div>
							</div>
							<ul class="jp-carousel-image-exif" style="display: none;"></ul>
							<a class="jp-carousel-image-download" target="_blank" style="display: none;">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white"/>
									</mask>
									<g mask="url(#mask0)">
										<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
								<span class="jp-carousel-download-text"></span>
							</a>
							<div class="jp-carousel-image-map" style="display: none;"></div>
						</div>
					</div>
				</div>
			</div>
		</div>

		</div>
		
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/frankreport.com\/2022\/05\/24\/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men\/":195194};
	</script>
					<div id="sharing_email" style="display: none;">
		<form action="/2022/05/24/swami-chetananda-demanded-female-disciples-pity-f-k-homeless-men/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://frankreport.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<style>.wp-container-1 {display: flex;gap: 0.5em;flex-wrap: wrap;align-items: center;justify-content: flex-start;align-items: center;}.wp-container-1 > * { margin: 0; }</style>
<style>.wp-container-2 > .alignleft { float: left; margin-inline-start: 0; margin-inline-end: 2em; }.wp-container-2 > .alignright { float: right; margin-inline-start: 2em; margin-inline-end: 0; }.wp-container-2 > .aligncenter { margin-left: auto !important; margin-right: auto !important; }</style>
<style>.wp-container-3 {display: flex;gap: 0.5em;flex-wrap: wrap;align-items: center;justify-content: flex-start;align-items: center;}.wp-container-3 > * { margin: 0; }</style>
<style>.wp-container-4 > .alignleft { float: left; margin-inline-start: 0; margin-inline-end: 2em; }.wp-container-4 > .alignright { float: right; margin-inline-start: 2em; margin-inline-end: 0; }.wp-container-4 > .aligncenter { margin-left: auto !important; margin-right: auto !important; }</style>
<link rel='stylesheet' id='all-css-80417022b188d6e0ba002d640e8fa132' href='https://frankreport.com/wp-content/mu-plugins/wpcomsh/widgets/author-grid/author-grid.css?m=1652837577' type='text/css' media='all' />
<script id='contact-form-7-js-extra'>
var wpcf7 = {"api":{"root":"https:\/\/frankreport.com\/wp-json\/","namespace":"contact-form-7\/v1"},"cached":"1"};
</script>
<script id='herald-main-js-extra'>
var herald_js_settings = {"ajax_url":"https:\/\/frankreport.com\/wp-admin\/admin-ajax.php","rtl_mode":"false","header_sticky":"1","header_sticky_offset":"200","header_sticky_up":"","single_sticky_bar":"1","popup_img":"1","logo":"https:\/\/frankreport.com\/wp-content\/uploads\/2021\/11\/logo-resized-1.svg","logo_retina":"https:\/\/frankreport.com\/wp-content\/uploads\/2021\/11\/logo-resized-1.svg","logo_mini":"https:\/\/frankreport.com\/wp-content\/uploads\/2021\/11\/logo-resized-1.svg","logo_mini_retina":"https:\/\/frankreport.com\/wp-content\/uploads\/2021\/11\/logo-resized-1.svg","smooth_scroll":"","trending_columns":"6"};
</script>
<script id='swp-live-search-client-js-extra'>
var searchwp_live_search_params = [];
searchwp_live_search_params = {"ajaxurl":"https:\/\/frankreport.com\/wp-admin\/admin-ajax.php","origin_id":195194,"config":{"default":{"engine":"default","input":{"delay":300,"min_chars":3},"results":{"position":"bottom","width":"auto","offset":{"x":0,"y":5}},"spinner":{"lines":12,"length":8,"width":3,"radius":8,"scale":1,"corners":1,"color":"#424242","fadeColor":"transparent","speed":1,"rotate":0,"animation":"searchwp-spinner-line-fade-quick","direction":1,"zIndex":2000000000,"className":"spinner","top":"50%","left":"50%","shadow":"0 0 1px transparent","position":"absolute"}}},"msg_no_config_found":"No valid SearchWP Live Search configuration found!","aria_instructions":"When autocomplete results are available use up and down arrows to review and enter to go to the desired page. Touch device users, explore by touch or with swipe gestures."};;
</script>
<script id='jetpack-carousel-js-extra'>
var jetpackSwiperLibraryPath = {"url":"https:\/\/frankreport.com\/wp-content\/plugins\/jetpack\/_inc\/build\/carousel\/swiper-bundle.min.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/frankreport.com\/wp-admin\/admin-ajax.php","nonce":"2cc64f3934","display_exif":"1","display_comments":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"0","login_url":"https:\/\/frankreport.com\/wp-login.php?redirect_to=https%3A%2F%2Ffrankreport.com%2F2022%2F05%2F24%2Fswami-chetananda-demanded-female-disciples-pity-f-k-homeless-men%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};
</script>
<script type='text/javascript'  src='https://frankreport.com/_static/??-eJyNkd1uwjAMhV9oJgNpG7uY9iiTSQ11yZ9st9C3J6wwVVOZdpXEPt/JiXMq4HMySuZK6A+c1HVkBf3RfXHybtdzaFxps+V0W1aR06rTp1OBqgh9Q5VR17CaGyg1WZzQgRIJWhaQPhlH+gdVWyWHcc8hzNS/413P6A32WSK8ubkZp4bOC5f4HGO1AKESxgVraylWZVsT18eiKtk39zhEpKMCoY6g2TMG0BaF5ig+ZJVQfFsbgQcC7PAMU+kHxwHVCxebxjPt/xjJwo95lNwrhXsP7oWbzWf8WL++bLbbzfv6+QJtYsMn'></script>
<script id='sharing-js-js-extra'>
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
</script>
<script src='https://frankreport.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=11.0-a.9' id='sharing-js-js'></script>
<script id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=103448067&postid=195194&comment_registration=0&require_name_email=0&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Please+leave+a+comment%3A+Your+opinion+is+important+to+us%21+%28Email+%26+username+are+optional%29&jetpack_comments_nonce=100e61571d&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=11.0-a.9&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=714ce134062451447324bbdd529e4941725bb8e9#parent=https%3A%2F%2Ffrankreport.com%2F2022%2F05%2F24%2Fswami-chetananda-demanded-female-disciples-pity-f-k-homeless-men%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=103448067&postid=195194&comment_registration=0&require_name_email=0&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Please+leave+a+comment%3A+Your+opinion+is+important+to+us%21+%28Email+%26+username+are+optional%29&jetpack_comments_nonce=100e61571d&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=11.0-a.9&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=714ce134062451447324bbdd529e4941725bb8e9#parent=https%3A%2F%2Ffrankreport.com%2F2022%2F05%2F24%2Fswami-chetananda-demanded-female-disciples-pity-f-k-homeless-men%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						}
					}
				})

			})();
		</script>

		<script src='https://stats.wp.com/e-202221.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:11.0-a.9',blog:'103448067',post:'195194',tz:'-5',srv:'frankreport.com',hp:'atomic',ac:'2',amp:'0'} ]);
	_stq.push([ 'clickTrackerInit', '103448067', '195194' ]);
</script>

</body>
</html>
<!--
	generated 32 seconds ago
	generated in 0.502 seconds
	served from batcache in 0.003 seconds
	expires in 268 seconds
-->
